summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecter1192022-03-16 16:18:52 +0800
committerspecter1192022-03-16 16:18:52 +0800
commitd98df839ba04f283ce8c0966623a41b142211b7d (patch)
tree3350a339de0b59999bfc7582947c5fe621595df9
parent27c82b9ca8cc0a1c00ab0f5e62d92ed0ee3ab62b (diff)
downloadaur-d98df839ba04f283ce8c0966623a41b142211b7d.tar.gz
v4.12.0, fix shell hook
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD44
2 files changed, 29 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2d8d3d406ef..5c0086889e5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-conda
pkgdesc = OS-agnostic, system-level binary package manager and ecosystem https://conda.io
- pkgver = 4.11.0
+ pkgver = 4.12.0
pkgrel = 1
url = https://github.com/conda/conda
arch = any
@@ -15,7 +15,7 @@ pkgbase = python-conda
provides = python-conda-env
options = !emptydirs
backup = etc/conda/condarc
- source = conda-4.11.0.tar.gz::https://github.com/conda/conda/archive/4.11.0.tar.gz
- sha512sums = 1cb457c2e3a395cc2512912c5e1299d7db928d033496ddb4c8c855d34ac7ab93bcd41d97f419638ac17237c9f79671eccd4a9d3bc747befb43606be5243a92ce
+ source = conda-4.12.0.tar.gz::https://github.com/conda/conda/archive/4.12.0.tar.gz
+ sha512sums = b8b51758a3edb80d0db72d404226a959ca3e6224ce23d2f46e5246537c6461f9ef1801b92901995e52dadef5015c3aa42019433b6f61058e40777b29d203b7cc
pkgname = python-conda
diff --git a/PKGBUILD b/PKGBUILD
index 5bd10290b45a..6e03a3e819c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-conda
_name=${pkgname#python-}
-pkgver=4.11.0
+pkgver=4.12.0
pkgrel=1
pkgdesc="OS-agnostic, system-level binary package manager and ecosystem https://conda.io"
arch=('any')
@@ -23,36 +23,44 @@ backup=(etc/conda/condarc)
source=(
$_name-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz
)
-sha512sums=('1cb457c2e3a395cc2512912c5e1299d7db928d033496ddb4c8c855d34ac7ab93bcd41d97f419638ac17237c9f79671eccd4a9d3bc747befb43606be5243a92ce')
+sha512sums=('b8b51758a3edb80d0db72d404226a959ca3e6224ce23d2f46e5246537c6461f9ef1801b92901995e52dadef5015c3aa42019433b6f61058e40777b29d203b7cc')
prepare() {
- cd "$srcdir/${_name}-$pkgver"
+ cd $srcdir/${_name}-$pkgver
echo $pkgver > conda/.version
- sed -i "s/package_files('conda\/shell') + //" setup.py
- sed -i 's/$_CONDA_ROOT//' conda/shell/bin/{de,}activate
+ # sed -i "s/package_files(\'conda\/shell') + //" setup.py
+ # sed -i 's/$_CONDA_ROOT//' conda/shell/bin/{de,}activate
sed -i 's/env python/python3/' conda/shell/bin/conda
- sed "s/conda.cli/conda_env.cli.main/" conda/shell/bin/conda > conda/shell/bin/conda-env
- echo 'set -l CONDA_EXE /usr/bin/conda' | cat - conda/shell/etc/fish/conf.d/conda.fish > conda.fish
- echo 'set _CONDA_EXE=/usr/bin/conda' | cat - conda/shell/etc/profile.d/conda.csh > conda.csh
- echo 'export CONDA_EXE=/usr/bin/conda' | cat - conda/shell/etc/profile.d/conda.sh > conda.sh
+ sed 's/conda.cli/conda_env.cli.main/' conda/shell/bin/conda > conda/shell/bin/conda-env
+ sed -i '3s/^/set _CONDA_EXE=\/usr\/bin\/conda\n/' conda/shell/etc/profile.d/conda.csh
+ sed -i '3s/^/export CONDA_EXE=\/usr\/bin\/conda\n/' conda/shell/etc/profile.d/conda.sh
+ sed -i '8s/^/set -l CONDA_EXE \/usr\/bin\/conda\n/' conda/shell/etc/fish/conf.d/conda.fish
+ # echo 'set -l CONDA_EXE /usr/bin/conda' | cat - conda/shell/etc/fish/conf.d/conda.fish > conda.fish
+ # echo 'set _CONDA_EXE=/usr/bin/conda' | cat - conda/shell/etc/profile.d/conda.csh > conda.csh
+ # echo 'export CONDA_EXE=/usr/bin/conda' | cat - conda/shell/etc/profile.d/conda.sh > conda.sh
echo -e 'envs_dirs:\n - ~/.conda/envs\npkgs_dirs:\n - ~/.conda/pkgs' > condarc
}
build() {
- cd "$srcdir/${_name}-$pkgver"
+ cd $srcdir/${_name}-$pkgver
python setup.py build
}
package() {
- cd "$srcdir/${_name}-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd $srcdir/${_name}-$pkgver
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
rm -f conda/shell/bin/{,de}activate
- for _bin in $(ls conda/shell/bin); do
- install -Dm 655 conda/shell/bin/$_bin $pkgdir/usr/bin/$_bin
- done
- install -Dm 644 conda.fish $pkgdir/usr/share/fish/functions/conda.fish
- install -Dm 644 conda.csh $pkgdir/etc/profile.d/conda.csh
- install -Dm 644 conda.sh $pkgdir/etc/profile.d/conda.sh
+ # for _bin in $(ls conda/shell/bin); do
+ # install -Dm 655 conda/shell/bin/$_bin $pkgdir/usr/bin/$_bin
+ # done
+ # install -Dm 644 conda.fish $pkgdir/usr/share/fish/functions/conda.fish
+ # install -Dm 644 conda.csh $pkgdir/etc/profile.d/conda.csh
+ # install -Dm 644 conda.sh $pkgdir/etc/profile.d/conda.sh
+ mkdir -p $pkgdir/{usr/share/fish/functions,etc/profile.d}
+ _dir_sitepackage=$(python -c 'import sysconfig; print(sysconfig.get_paths()["purelib"])')
+ ln -s ${_dir_sitepackage}/conda/shell/etc/fish/conf.d/conda.fish $pkgdir/usr/share/fish/functions/conda.fish
+ ln -s ${_dir_sitepackage}/conda/shell/etc/profile.d/conda.csh $pkgdir/etc/profile.d/conda.csh
+ ln -s ${_dir_sitepackage}/conda/shell/etc/profile.d/conda.sh $pkgdir/etc/profile.d/conda.sh
install -Dm 644 condarc $pkgdir/etc/conda/condarc
install -Dm 644 LICENSE.txt $pkgdir/usr/share/licenses/${pkgname}/LICENSE.txt
}