summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Maslowski2018-05-02 01:55:02 +0200
committerDaniel Maslowski2018-05-02 01:55:12 +0200
commit9642ffb5d6be1956aac66b2abef49418f2689331 (patch)
tree16e1a45a7baa02d35dd0d55900976fcb16ee34a6
parenta15543c06b312e1f21c365e710c42e53fd2ce1b4 (diff)
downloadaur-9642ffb5d6be1956aac66b2abef49418f2689331.tar.gz
include conda-env in bin
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42888cb51905..a47f27b2440d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue May 1 23:53:09 UTC 2018
+# Tue May 1 23:55:05 UTC 2018
pkgbase = python-conda-git
pkgdesc = OS-agnostic, system-level binary package manager and ecosystem
pkgver = 4.5.0.r39.g31130cd80
- pkgrel = 1
+ pkgrel = 2
url = http://conda.pydata.org/docs/
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 89b97141afe4..002e688b6a1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_gitname=conda
pkgname=python-${_gitname}-git
pkgver=4.5.0.r39.g31130cd80
-pkgrel=1
+pkgrel=2
pkgdesc="OS-agnostic, system-level binary package manager and ecosystem"
arch=('any')
url="http://conda.pydata.org/docs/"
@@ -34,8 +34,10 @@ package() {
cd "$srcdir/${_gitname}"
echo $pkgver > conda/.version
python utils/setup-testing.py install --root="$pkgdir/" --optimize=1
+ sed "s/conda.cli/conda_env.cli.main/" conda/shell/bin/conda > conda/shell/bin/conda-env
install -Dm 655 conda/shell/bin/activate $pkgdir/usr/bin/activate
install -Dm 655 conda/shell/bin/conda $pkgdir/usr/bin/conda
+ install -Dm 655 conda/shell/bin/conda-env $pkgdir/usr/bin/conda-env
install -Dm 655 conda/shell/bin/deactivate $pkgdir/usr/bin/deactivate
echo 'set _CONDA_EXE /usr/bin/conda
set _CONDA_ROOT /' | cat - conda/shell/etc/fish/conf.d/conda.fish > conda.fish