summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Maslowski2016-04-08 09:40:53 +0200
committerDaniel Maslowski2016-04-08 09:40:53 +0200
commitecda997c472dbc9f8ef215e97e7a9e0959c6a9fa (patch)
tree8ff1866ff7255f927414653f58176546bb81275e
downloadaur-ecda997c472dbc9f8ef215e97e7a9e0959c6a9fa.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD35
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..395410180c86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Apr 8 07:40:19 UTC 2016
+pkgbase = python-conda-git
+ pkgdesc = OS-agnostic, system-level binary package manager and ecosystem
+ pkgver = 4.0.5.r225.g5518a64
+ pkgrel = 1
+ url = http://conda.pydata.org/docs/
+ arch = any
+ license = custom
+ makedepends = git
+ depends = python
+ depends = python-psutil
+ depends = python-pycosat
+ depends = python-requests
+ depends = python-yaml
+ provides = activate
+ provides = conda
+ provides = deactivate
+ options = !emptydirs
+ source = git+https://github.com/conda/conda
+ md5sums = SKIP
+
+pkgname = python-conda-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12691a150610
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniel Maslowski <info@orangecms.org>
+
+_gitname=conda
+pkgname=python-${_gitname}-git
+pkgver=4.0.5.r225.g5518a64
+pkgrel=1
+pkgdesc="OS-agnostic, system-level binary package manager and ecosystem"
+arch=('any')
+url="http://conda.pydata.org/docs/"
+license=('custom')
+groups=()
+depends=('python' 'python-psutil' 'python-pycosat' 'python-requests' 'python-yaml')
+makedepends=('git')
+provides=('activate' 'conda' 'deactivate')
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("git+https://github.com/$_gitname/$_gitname")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${_gitname}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm 644 bin/conda.fish $pkgdir/usr/share/fish/functions/conda.fish
+ install -Dm 644 LICENSE.txt $pkgdir/usr/share/licenses/${pkgname}/LICENSE.txt
+}
+
+# vim:set ts=2 sw=2 et: