summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2018-09-15 14:55:32 +0200
committerRichard Neumann2018-09-15 14:55:32 +0200
commit9ea30f917dfd73df0e527951c19a779acf8c32dc (patch)
treeefd0891ad5a9b8a7b6377f27f2b3f4836754c38c
downloadaur-9ea30f917dfd73df0e527951c19a779acf8c32dc.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92ceb89a75cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-configlib-git
+ pkgdesc = An extended configuration parsing library
+ pkgver = latest
+ pkgrel = 1
+ url = https://gitlab.com/HOMEINFO/configlib
+ arch = any
+ license = GPLv3
+ makedepends = git
+ makedepends = python
+ depends = python
+ provides = python-configlib
+ conflicts = python-configlib
+ source = configlib::git+https://gitlab.com/HOMEINFO/configlib.git
+ md5sums = SKIP
+
+pkgname = python-configlib-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c28e8139fc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+_pkgbase='configlib'
+pkgname="python-${_pkgbase}-git"
+pkgver=latest
+pkgrel=1
+pkgdesc='An extended configuration parsing library'
+arch=('any')
+url="https://gitlab.com/HOMEINFO/${_pkgbase}"
+license=('GPLv3')
+depends=('python')
+makedepends=('git' 'python')
+provides=("python-${_pkgbase}")
+conflicts=("python-${_pkgbase}")
+source=("${_pkgbase}::git+${url}.git")
+md5sums=('SKIP')
+pkgdir='pkg'
+srcdir='src'
+
+
+pkgver() {
+ cd "${_pkgbase}" || exit 1
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}