summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Ramos Rehermann2023-09-05 17:26:23 -0300
committerGustavo Ramos Rehermann2023-09-05 17:26:23 -0300
commit5e94cb3b7c62b763a4e277f7615b24503db48b9a (patch)
tree95410ced27b2ec30fc2f919ecdcf6c0d17816345
parente4d85a6c42010b252d0b0bcaebda2bcb0ed202c9 (diff)
downloadaur-5e94cb3b7c62b763a4e277f7615b24503db48b9a.tar.gz
Fix building standards based Python package
see https://wiki.archlinux.org/title/Python_package_guidelines#Standards_based_(PEP_517)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cac710b1e43b..84fb1abb6788 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,10 @@ pkgbase = python-configparser
url = https://github.com/jaraco/configparser/
arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-wheel
+ makedepends = python-setuptools-scm
depends = python
source = git+https://github.com/jaraco/configparser.git#tag=v6.0.0
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 109508d7968d..ae4b6ac20abf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: Gustavo Rehermann <rehermann6046@gmail.com>
# Maintainer: Philip May <eniak.info@gmail.com>
pkgname=python-configparser
@@ -10,19 +11,20 @@ url='https://github.com/jaraco/configparser/'
license=('MIT')
depends=('python')
makedepends=(
- 'python-setuptools'
- 'python-pip'
- 'python-wheel'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-setuptools-scm'
)
source=("git+https://github.com/jaraco/${_pkgname}.git#tag=v${pkgver}")
sha256sums=('SKIP')
build() {
- cd "${srcdir}/${_pkgname}"
- python setup.py build
+ cd "${srcdir}/${_pkgname}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pkgname}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "${srcdir}/${_pkgname}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}