summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2018-08-15 12:49:36 -0700
committerDonald Webster2018-08-15 12:49:36 -0700
commita09e8c3e56d94d63dc11ddbc2a1c152e6a17385f (patch)
treecbda4de76460020c41a6f3b0df30917bde2c258d
downloadaur-a09e8c3e56d94d63dc11ddbc2a1c152e6a17385f.tar.gz
Initial version of python-configparser.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..732bea0a8d47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-configparser
+ pkgdesc = This library brings the updated configparser from Python 3.5 to Python 2.6-3.5.
+ pkgver = 3.5.0
+ pkgrel = 1
+ url = http://docs.python.org/3/library/configparser.html
+ arch = any
+ license = MIT
+ makedepends = python3
+ depends = python
+ source = https://files.pythonhosted.org/packages/7c/69/c2ce7e91c89dc073eb1aa74c0621c3eefbffe8216b3f9af9d3885265c01c/configparser-3.5.0.tar.gz
+ md5sums = cfdd915a5b7a6c09917a64a573140538
+
+pkgname = python-configparser
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..97484cf0bb87
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.xz
+/*.gz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee5cc0edfb65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+#Automatically generated by pip2arch on 2018-08-15
+
+pkgname=python-configparser
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="This library brings the updated configparser from Python 3.5 to Python 2.6-3.5."
+url="http://docs.python.org/3/library/configparser.html"
+depends=('python' )
+makedepends=('python3' )
+license=('MIT')
+arch=('any')
+source=('https://files.pythonhosted.org/packages/7c/69/c2ce7e91c89dc073eb1aa74c0621c3eefbffe8216b3f9af9d3885265c01c/configparser-3.5.0.tar.gz')
+md5sums=('cfdd915a5b7a6c09917a64a573140538')
+
+build() {
+ cd $srcdir/configparser-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/configparser-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1
+}