summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipMay2020-04-07 08:47:13 +0200
committerPhilipMay2020-04-07 08:47:13 +0200
commitf630dfa500eb20fb4e7bfa1f0eea27b8bcc815e5 (patch)
treef87c314928acb103be523d827cd2b7132b008cf1
parent899553efa1bbe7b5997068642b8d37aca779b738 (diff)
downloadaur-f630dfa500eb20fb4e7bfa1f0eea27b8bcc815e5.tar.gz
first version (5.0.0) of python-configparser
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 020b6c849965..d37969f66676 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-configparser
- pkgdesc = This library brings the updated configparser from Python 3.5 to Python 2.6-3.5.
- pkgver = 4.0.2
+ pkgdesc = backport of configparser from Python 3
+ pkgver = 5.0.0
pkgrel = 1
- url = https://github.com/jaraco/configparser
+ url = https://github.com/jaraco/configparser/
arch = any
license = MIT
- makedepends = python-setuptools-scm
- depends = python
- conflicts = python-libconfigparser
- replaces = python-libconfigparser
- source = https://pypi.org/packages/source/c/configparser/configparser-4.0.2.tar.gz
- sha256sums = c7d282687a5308319bf3d2e7706e575c635b0a470342641c93bea0ea3b5331df
+ makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python-wheel
+ source = git+https://github.com/jaraco/configparser.git#tag=v5.0.0
+ sha256sums = SKIP
pkgname = python-configparser
diff --git a/PKGBUILD b/PKGBUILD
index 428ca07c2a15..d8a9d8d34ed3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
-# Co-Maintainer: peeweep
+# Maintainer: Philip May <eniak.info@gmail.com>
+
pkgname=python-configparser
-_name=${pkgname#python-}
-pkgver=4.0.2
+_pkgname=configparser
+pkgver=5.0.0
pkgrel=1
-pkgdesc="This library brings the updated configparser from Python 3.5 to Python 2.6-3.5."
+pkgdesc='backport of configparser from Python 3'
arch=('any')
-url="https://github.com/jaraco/configparser"
+url='https://github.com/jaraco/configparser/'
license=('MIT')
-depends=('python')
-makedepends=('python-setuptools-scm')
-conflicts=('python-libconfigparser')
-replaces=('python-libconfigparser')
-source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('c7d282687a5308319bf3d2e7706e575c635b0a470342641c93bea0ea3b5331df')
+depends=()
+optdepends=()
+makedepends=(
+ 'python-setuptools'
+ 'python-pip'
+ 'python-wheel'
+ )
+source=("git+https://github.com/jaraco/${_pkgname}.git#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
- cd "$_name-$pkgver"
- python setup.py build
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
}
package() {
- cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}