summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2014-09-30 23:52:55 +0200
committerJohannes Dewender2014-09-30 23:52:55 +0200
commit2ba28a29897fd2bf7427c18dd1dc9b750e558f8f (patch)
tree37bfcdbff822895e0593dac6ccc3134064526b28
parentf95c2b37e67b75d6d0c22928a307911e9f2111a4 (diff)
downloadaur-2ba28a29897fd2bf7427c18dd1dc9b750e558f8f.tar.gz
python(2)-configshell-fb: use split packaging
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 34 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdd6bbda0aae..0d38d97d7943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = python-configshell-fb
pkgdesc = python framework for building simple CLI applications (free branch)
pkgver = 1.1.fb15
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/agrover/configshell-fb
arch = any
license = Apache
- makedepends = python-setuptools
+ source = https://fedorahosted.org/releases/t/a/targetcli-fb/configshell-fb-1.1.fb15.tar.gz
+ sha256sums = 7e645509acff3e92d4b824be48cdca1ba059e94ae9f9e0bdedd5829c310518d9
+
+pkgname = python-configshell-fb
depends = python-pyparsing
depends = python-urwid
provides = python-configshell
conflicts = python-configshell
- source = https://fedorahosted.org/releases/t/a/targetcli-fb/configshell-fb-1.1.fb15.tar.gz
- sha256sums = 7e645509acff3e92d4b824be48cdca1ba059e94ae9f9e0bdedd5829c310518d9
-pkgname = python-configshell-fb
+pkgname = python2-configshell-fb
+ depends = python2-pyparsing
+ depends = python2-urwid
+ provides = python2-configshell
+ conflicts = python2-configshell
diff --git a/PKGBUILD b/PKGBUILD
index 0a9f55686526..48c3083eca1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,42 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
-pkgname=python-configshell-fb
+pkgname=('python-configshell-fb' 'python2-configshell-fb')
_pkgname=configshell-fb
pkgver=1.1.fb15
-pkgrel=1
+pkgrel=2
pkgdesc="python framework for building simple CLI applications (free branch)"
arch=('any')
url="https://github.com/agrover/configshell-fb"
license=('Apache')
-depends=('python-pyparsing' 'python-urwid')
-makedepends=('python-setuptools')
-provides=('python-configshell')
-conflicts=('python-configshell')
options=()
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz)
sha256sums=('7e645509acff3e92d4b824be48cdca1ba059e94ae9f9e0bdedd5829c310518d9')
-build() {
+
+build_python-configshell-fb() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py build
}
-package() {
+build_python2-configshell-fb() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+
+package_python-configshell-fb() {
+ depends=('python-pyparsing' 'python-urwid')
+ makedepends=('python-setuptools')
+ provides=('python-configshell')
+ conflicts=('python-configshell')
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+}
+
+package_python2-configshell-fb() {
+ depends=('python2-pyparsing' 'python2-urwid')
+ makedepends=('python2-setuptools')
+ provides=('python2-configshell')
+ conflicts=('python2-configshell')
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --skip-build --root="$pkgdir/" --optimize=1
}