summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sampson2021-02-16 19:27:08 +1100
committerMike Sampson2021-02-16 19:27:08 +1100
commit2fa1a280dbaab23a48f0cb50c3dfdd433f534570 (patch)
tree3fedc7379a1a3144eda4955ba20958b6302ac142
parentf3f7b676aa83f5bd34b3e5a188987bc1a3e0b2f5 (diff)
downloadaur-2fa1a280dbaab23a48f0cb50c3dfdd433f534570.tar.gz
Remove Python 2 support
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9eee6e4a044e..7c978f1db5f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,17 @@
pkgbase = python-configshell-fb
pkgdesc = python framework for building simple CLI applications (free branch)
pkgver = 1.1.28
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/open-iscsi/configshell-fb
arch = any
license = Apache
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://github.com/open-iscsi/configshell-fb/archive/v1.1.28.tar.gz
- sha512sums = 4cdc3ee72fc7c4bffcf2f508eef16cc8578d1358ceeb70050a619f5e93e0e189de7216ac0baa77af98fb1b7569940a22a0e3cd977cd460bb91252b4ab176d0f4
-
-pkgname = python-configshell-fb
depends = python-pyparsing
depends = python-urwid
provides = python-configshell
conflicts = python-configshell
+ source = https://github.com/open-iscsi/configshell-fb/archive/v1.1.28.tar.gz
+ sha512sums = 4cdc3ee72fc7c4bffcf2f508eef16cc8578d1358ceeb70050a619f5e93e0e189de7216ac0baa77af98fb1b7569940a22a0e3cd977cd460bb91252b4ab176d0f4
-pkgname = python2-configshell-fb
- depends = python2-pyparsing
- depends = python2-urwid
- provides = python2-configshell
- conflicts = python2-configshell
+pkgname = python-configshell-fb
diff --git a/PKGBUILD b/PKGBUILD
index 218c63db478e..25f266cbc092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
-pkgname=('python-configshell-fb' 'python2-configshell-fb')
+pkgname=python-configshell-fb
_pkgname=configshell-fb
pkgver=1.1.28
-pkgrel=1
+pkgrel=2
pkgdesc="python framework for building simple CLI applications (free branch)"
arch=('any')
url="https://github.com/open-iscsi/configshell-fb"
license=('Apache')
options=()
-makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python-pyparsing' 'python-urwid')
+makedepends=('python-setuptools')
+provides=('python-configshell')
+conflicts=('python-configshell')
source=(https://github.com/open-iscsi/configshell-fb/archive/v${pkgver}.tar.gz)
sha512sums=('4cdc3ee72fc7c4bffcf2f508eef16cc8578d1358ceeb70050a619f5e93e0e189de7216ac0baa77af98fb1b7569940a22a0e3cd977cd460bb91252b4ab176d0f4')
-package_python-configshell-fb() {
- depends=('python-pyparsing' 'python-urwid')
- provides=('python-configshell')
- conflicts=('python-configshell')
+package() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}
-package_python2-configshell-fb() {
- depends=('python2-pyparsing' 'python2-urwid')
- provides=('python2-configshell')
- conflicts=('python2-configshell')
- cd "$srcdir/$_pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
-}
-
# vim:set ts=2 sw=2 et: