summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-10-17 21:24:54 +0200
committerJohannes Dewender2013-10-17 21:24:54 +0200
commit89bfea18a95ccfcece3c4953ba5de978c8e69f1d (patch)
treefffe5b9c7df26a1ad42c685e8b562332104cdbfa
downloadaur-89bfea18a95ccfcece3c4953ba5de978c8e69f1d.tar.gz
python-configshell-fb: create as 1.1.fb9
using 2to3 patch from upstream
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore8
-rw-r--r--2to3.patch47
-rw-r--r--PKGBUILD34
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a53cb4155b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-configshell-fb
+ pkgdesc = python framework for building simple CLI applications (free branch)
+ pkgver = 1.1.fb9
+ pkgrel = 1
+ url = https://github.com/agrover/configshell-fb
+ arch = any
+ license = Apache
+ depends = python-pyparsing
+ depends = python-urwid
+ provides = python-configshell
+ conflicts = python-configshell
+ source = https://fedorahosted.org/releases/t/a/targetcli-fb/configshell-fb-1.1.fb9.tar.gz
+ source = 2to3.patch
+ md5sums = 48b7c9be66c9e450585598504c2fde45
+ md5sums = d0413e9d1a8dca6df0c92aa9a4a2bf54
+
+pkgname = python-configshell-fb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd9b4a41adc0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.gz
+*.tar.xz
+*.tgz
+*.rpm
+*.zip
+*.bz2
+src/
+pkg/
diff --git a/2to3.patch b/2to3.patch
new file mode 100644
index 000000000000..61425a98f045
--- /dev/null
+++ b/2to3.patch
@@ -0,0 +1,47 @@
+From 8aead336aca910e015faaa032da519518976ee72 Mon Sep 17 00:00:00 2001
+From: Christophe Vu-Brugier <cvubrugier@yahoo.fr>
+Date: Sat, 12 Oct 2013 18:37:22 +0200
+Subject: [PATCH] Use 2to3 in setup and mention that configshell-fb is Python 3
+ compatible
+
+Signed-off-by: Christophe Vu-Brugier <cvubrugier@yahoo.fr>
+---
+ README.md | 2 ++
+ setup.py | 3 ++-
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/README.md b/README.md
+index 3f59325..3da1424 100644
+--- a/README.md
++++ b/README.md
+@@ -6,6 +6,8 @@ A Python library for building configuration shells
+ configshell-fb is a Python library that provides a framework
+ for building simple but nice CLI-based applications.
+
++This runs with Python 2 and 2to3 is run by setup.py to run on Python 3.
++
+ configshell-fb development
+ --------------------------
+ configshell-fb is licensed under the Apache 2.0 license. Contributions are welcome.
+diff --git a/setup.py b/setup.py
+index e17c7a0..4743008 100755
+--- a/setup.py
++++ b/setup.py
+@@ -16,7 +16,7 @@ License for the specific language governing permissions and limitations
+ under the License.
+ '''
+
+-from distutils.core import setup
++from setuptools import setup
+
+ setup(
+ name = 'configshell-fb',
+@@ -27,4 +27,5 @@ setup(
+ maintainer_email = 'agrover@redhat.com',
+ url = 'http://github.com/agrover/configshell-fb',
+ packages = ['configshell'],
++ use_2to3 = True,
+ )
+--
+1.8.4.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afef55390027
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+pkgname=python-configshell-fb
+_pkgname=configshell-fb
+pkgver=1.1.fb9
+pkgrel=1
+epoch=
+pkgdesc="python framework for building simple CLI applications (free branch)"
+arch=('any')
+url="https://github.com/agrover/configshell-fb"
+license=('Apache')
+depends=('python-pyparsing' 'python-urwid')
+provides=('python-configshell')
+conflicts=('python-configshell')
+options=()
+source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz 2to3.patch)
+md5sums=('48b7c9be66c9e450585598504c2fde45'
+ 'd0413e9d1a8dca6df0c92aa9a4a2bf54')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 < ../2to3.patch
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: