summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2014-12-05 07:41:42 +0100
committerJohannes Dewender2014-12-05 07:41:42 +0100
commitd7e0853070f360604a1c611cc2fcfdaaa60aa972 (patch)
tree3e945043e18d830ea28f43029a5908a4f5be1f87
parent212f69df0badf7e197a600fea97ee6b4c2466920 (diff)
downloadaur-d7e0853070f360604a1c611cc2fcfdaaa60aa972.tar.gz
python-rtslib-fb: move makedepends up
This doesn't work on "package level".
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddfa25048fd9..3acc7e0c5c73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = python-configshell-fb
pkgdesc = python framework for building simple CLI applications (free branch)
pkgver = 1.1.fb16
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/agrover/configshell-fb
arch = any
license = Apache
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
source = https://fedorahosted.org/releases/t/a/targetcli-fb/configshell-fb-1.1.fb16.tar.gz
sha256sums = 391187e213bcec4eb81d34baad973afd6ff544af1fe07816ff784a3eb278e0c5
diff --git a/PKGBUILD b/PKGBUILD
index f719581eb4c0..1425ef7ced15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=('python-configshell-fb' 'python2-configshell-fb')
_pkgname=configshell-fb
pkgver=1.1.fb16
-pkgrel=1
+pkgrel=2
pkgdesc="python framework for building simple CLI applications (free branch)"
arch=('any')
url="https://github.com/agrover/configshell-fb"
license=('Apache')
options=()
+makedepends=('python-setuptools' 'python2-setuptools')
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz)
sha256sums=('391187e213bcec4eb81d34baad973afd6ff544af1fe07816ff784a3eb278e0c5')
package_python-configshell-fb() {
depends=('python-pyparsing' 'python-urwid')
- makedepends=('python-setuptools')
provides=('python-configshell')
conflicts=('python-configshell')
cd "$srcdir/$_pkgname-$pkgver"
@@ -22,7 +22,6 @@ package_python-configshell-fb() {
package_python2-configshell-fb() {
depends=('python2-pyparsing' 'python2-urwid')
- makedepends=('python2-setuptools')
provides=('python2-configshell')
conflicts=('python2-configshell')
cd "$srcdir/$_pkgname-$pkgver"