summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-11-24 22:14:30 +0100
committerMichel Zou2019-11-24 22:14:30 +0100
commit8afdf1be3fd56484f898ebbe045704b4dc43604b (patch)
tree4f4a82017359b496cb82f54ece0ba3f4b22d4051
downloadaur-8afdf1be3fd56484f898ebbe045704b4dc43604b.tar.gz
3.7.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d316fb12cffe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-configurationutil
+ pkgdesc = A collection of state machine utilities
+ pkgver = 3.7.2
+ pkgrel = 1
+ url = https://bitbucket.org/daycoder/configurationutil
+ arch = any
+ license = custom:PSF
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.io/packages/source/c/configurationutil/configurationutil-3.7.2.tar.gz
+ sha512sums = SKIP
+
+pkgname = python-configurationutil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce888cbc5cec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=python-configurationutil
+pkgver=3.7.2
+pkgrel=1
+pkgdesc="A collection of state machine utilities"
+arch=(any)
+url="https://bitbucket.org/daycoder/configurationutil"
+license=('custom:PSF')
+makedepends=('python-setuptools')
+depends=('python')
+source=("https://pypi.io/packages/source/c/configurationutil/configurationutil-$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+check() {
+ # Not included in release tarball
+ cd configurationutil-$pkgver
+ # python test_configurationutil.py
+}
+
+package() {
+ cd configurationutil-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+}