summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Claßen2020-08-25 17:19:40 +0200
committerPhilipp Claßen2020-08-25 17:19:40 +0200
commitf90c52b9412575268f177e8f7daadd6cf5f89590 (patch)
treea7a70d26aae333911b6618d638f14d8da7e9a292
downloadaur-f90c52b9412575268f177e8f7daadd6cf5f89590.tar.gz
Initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58c9c90dc45f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-confluent_kafka
+ pkgdesc = Confluent's Kafka Python Client
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/confluentinc/confluent-kafka-python
+ arch = x86_64
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ depends = librdkafka
+ source = python-confluent_kafka-1.5.0.tar.gz::https://github.com/confluentinc/confluent-kafka-python/archive/v1.5.0.tar.gz
+ sha512sums = 8ac0e021a85932eef4034940d0d620788753ccc585e5b26f066ae62e4db5a5595e16a40e6f6a70160ee9f43e7fbe3c99416c68f844cc737cdf762bda7c0a0bb4
+
+pkgname = python-confluent_kafka
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..406f4f38d420
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
+
+pkgname=python-confluent_kafka
+_pkgname=confluent-kafka-python
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Confluent's Kafka Python Client"
+arch=('x86_64')
+license=('Apache')
+url="https://github.com/confluentinc/confluent-kafka-python"
+depends=('python' 'librdkafka')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/confluentinc/confluent-kafka-python/archive/v${pkgver}.tar.gz")
+sha512sums=('8ac0e021a85932eef4034940d0d620788753ccc585e5b26f066ae62e4db5a5595e16a40e6f6a70160ee9f43e7fbe3c99416c68f844cc737cdf762bda7c0a0bb4')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py clean
+ rm -rf build dist
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm "${pkgdir}/usr/LICENSE.txt"
+}