summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-22 23:14:08 -0500
committerCarlos Aznarán2024-02-22 23:14:08 -0500
commit04b3cad7e2f7f754e69e77b9e0312fc7336f7c74 (patch)
treefbca37a2d1fd69da1120bad7406d6fdf8b055a52
parent0da68280b24ef6afc8bf440411e415e15b29a47c (diff)
downloadaur-04b3cad7e2f7f754e69e77b9e0312fc7336f7c74.tar.gz
Bump version to 1.9.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--CHANGELOG.md14
-rw-r--r--PKGBUILD42
4 files changed, 45 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07ef93410ec4..fd1df8c29805 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python-confu
pkgdesc = Configuration file validation and generation
- pkgver = 1.8.0
- pkgrel = 2
+ pkgver = 1.9.0
+ pkgrel = 1
url = https://github.com/20c/confu
changelog = CHANGELOG.md
arch = any
- license = Apache
+ license = Apache-2.0
checkdepends = python-pytest
- checkdepends = python-click
- makedepends = python-poetry-core
makedepends = python-build
makedepends = python-installer
- depends = python
- source = python-confu-1.8.0.tar.gz::https://github.com/20c/confu/archive/1.8.0.tar.gz
- sha256sums = e981f0f48374c01f2ffbfc0c043000a0168a6fce023c7068e594bf95f1b3647b
+ makedepends = python-poetry-core
+ depends = python-munge
+ source = confu-1.9.0.tar.gz::https://github.com/20c/confu/archive/1.9.0.tar.gz
+ sha512sums = a0943cb496cd9816ca6060ed527123f479b0cafc5f2c01e7c747f5845d99840bdb77727bfc5d158a8febad278cc49b64f0b0060fcd8425c2c428a5652bac9afd
pkgname = python-confu
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 88afcae6a68a..6e884bbfa94e 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,6 +4,20 @@
## Unreleased
+## 1.9.0
+### Added
+- add `SettingsManager.set_list()`
+- add `SettingsManager.try_include()`
+- Python 3.10 support (#64)
+- Python 3.11 support
+- Python 3.12 support
+### Changed
+- documentation moved to github pages
+### Removed
+- Python 3.6 support
+- Python 3.7 support
+
+
## 1.8.0
### Added
- inet type `IpNetwork`
diff --git a/PKGBUILD b/PKGBUILD
index d563a924e300..bb4e5d280939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,34 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-
-pkgname=python-confu
-pkgver=1.8.0
-pkgrel=2
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+_base=confu
+pkgname=python-${_base}
+pkgver=1.9.0
+pkgrel=1
pkgdesc="Configuration file validation and generation"
-arch=('any')
-url="https://github.com/20c/confu"
-license=('Apache')
-depends=('python')
-makedepends=('python-poetry-core' 'python-build' 'python-installer')
-checkdepends=('python-pytest' 'python-click')
+arch=(any)
+url="https://github.com/20c/${_base}"
+license=(Apache-2.0)
+depends=(python-munge)
+makedepends=(python-build python-installer python-poetry-core)
+checkdepends=(python-pytest)
changelog=CHANGELOG.md
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('e981f0f48374c01f2ffbfc0c043000a0168a6fce023c7068e594bf95f1b3647b')
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('a0943cb496cd9816ca6060ed527123f479b0cafc5f2c01e7c747f5845d99840bdb77727bfc5d158a8febad278cc49b64f0b0060fcd8425c2c428a5652bac9afd')
build() {
- cd "confu-$pkgver"
- python -m build --wheel --no-isolation
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd "confu-$pkgver"
- PYTHONPATH=./src pytest -x
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest tests
}
package() {
- cd "confu-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}