summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhang.j.k2021-01-24 18:50:49 +0800
committerzhang.j.k2021-01-24 18:50:49 +0800
commitbce05621547443e46127016bef8b97c58223166e (patch)
treec53b1de071f6808e92958e650d104ae5d0767775
downloadaur-bce05621547443e46127016bef8b97c58223166e.tar.gz
init package conllu
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore22
-rw-r--r--PKGBUILD26
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ca49650d9cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-conllu
+ pkgdesc = CoNLL-U Parser parses a CoNLL-U formatted string into a nested python dictionary
+ pkgver = 4.3
+ pkgrel = 1
+ url = https://github.com/EmilStenstrom/conllu/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/c/conllu/conllu-4.3.tar.gz
+ sha256sums = 35b5b76280507977e9e86f18369a1a4e5d4075a3680f1e9b2fac7ed5d0aaf427
+
+pkgname = python-conllu
+ depends = python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..630171850851
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,22 @@
+*.tar.zst
+python-conllu/
+pkg/
+src/
+
+# ignore everything
+*
+!.gitignore
+
+# except PKGBUILD needed files
+!PKGBUILD
+!.SRCINFO
+!*.install
+!ChangeLog
+
+# common wing-man files
+!*.diff
+!*.patch
+
+!README.md
+
+# add files that don't have an online source \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d64fedf48929
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Zhang.j.k <zhangjk67 at gmail dian com>
+
+pkgbase='python-conllu'
+pkgname=('python-conllu')
+_module='conllu'
+pkgver='4.3'
+pkgrel=1
+pkgdesc="CoNLL-U Parser parses a CoNLL-U formatted string into a nested python dictionary"
+url="https://github.com/EmilStenstrom/conllu/"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('35b5b76280507977e9e86f18369a1a4e5d4075a3680f1e9b2fac7ed5d0aaf427')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}