summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-22 20:34:21 -0600
committerLuis Martinez2022-02-22 20:34:21 -0600
commit4f1a628e23a6c81f8f16e407a0f8b4d320078e60 (patch)
tree0fcff5d1761c6fd03af0c763791a76299f53160a
parent0df5afdf3399b314bd5687129d720e0077bad611 (diff)
downloadaur-4f1a628e23a6c81f8f16e407a0f8b4d320078e60.tar.gz
use python-installer for packaging
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef52ba5a0e80..31b23fb677f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-contexter
pkgdesc = Full replacement of the contextlib standard library module
pkgver = 0.1.4
- pkgrel = 2
+ pkgrel = 3
url = https://bitbucket.org/defnull/contexter
arch = any
license = MIT
makedepends = python-setuptools
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-wheel
depends = python
source = python-contexter-0.1.4.tar.gz::https://files.pythonhosted.org/packages/source/c/contexter/contexter-0.1.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 1b180ddcacae..b0021ff5f26f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=python-contexter
pkgver=0.1.4
-pkgrel=2
+pkgrel=3
pkgdesc='Full replacement of the contextlib standard library module'
arch=('any')
url=https://bitbucket.org/defnull/contexter
license=('MIT')
depends=('python')
-makedepends=('python-setuptools' 'python-build' 'python-install' 'python-wheel')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/contexter/contexter-$pkgver.tar.gz"
'001-setup.py.patch'
'LICENSE')
@@ -23,13 +23,13 @@ prepare() {
build() {
cd "contexter-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
}
package() {
export PYTHONHASHSEED=0
cd "contexter-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}