summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2018-04-03 15:03:43 -0700
committerTyler Veness2018-04-03 15:03:43 -0700
commitd25af8b77c918ea4832dcf784d14b85b59850525 (patch)
tree1c30f0664971df52bc4cf4468a8f1f3785c3f1c8
parent938bbdab763c1017d932f689217ee634faac74f2 (diff)
downloadaur-d25af8b77c918ea4832dcf784d14b85b59850525.tar.gz
Cleaned up python2 packaging
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bccfd6c7ebd3..c92c0edbd9fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-control
pkgdesc = Implements basic operations for analysis and design of feedback control systems in Python
pkgver = 0.7.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/python-control/python-control
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 7a2c5a45cd9c..3b769344789d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-control
pkgname=('python2-control' 'python-control')
pkgver=0.7.0
-pkgrel=5
+pkgrel=6
pkgdesc="Implements basic operations for analysis and design of feedback control systems in Python"
arch=('any')
license=('BSD')
@@ -20,8 +20,8 @@ md5sums=('9ae5f99eb8e8ec242b108bbbcea0c990'
'5e21e2b8826c3345f50711d5634bc975')
prepare() {
- cp -a python-control-$pkgver control-py2-$pkgver
- cd control-py2-$pkgver
+ cp -a python-control-$pkgver python2-control-$pkgver
+ cd python2-control-$pkgver
sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
@@ -33,7 +33,7 @@ build() {
export LDFLAGS="$LDFLAGS -shared"
echo "Building Python2"
- cd control-py2-$pkgver
+ cd python2-control-$pkgver
python2 setup.py build
echo "Building Python3"
@@ -49,7 +49,7 @@ check() {
package_python2-control() {
export LDFLAGS="$LDFLAGS -shared"
- cd control-py2-$pkgver
+ cd python2-control-$pkgver
python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
install -m755 -d "${pkgdir}/usr/share/licenses/python2-control"