summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomas Krizek2019-11-19 14:39:44 +0100
committerTomas Krizek2019-11-19 14:39:44 +0100
commitdb5de8e0301eac4e6d442cd471332478378ed7d6 (patch)
tree5bcb65453d205f1a3b29a256889bff349b85cc26
downloadaur-db5de8e0301eac4e6d442cd471332478378ed7d6.tar.gz
initial package
-rw-r--r--.SRCINFO35
-rw-r--r--0001-requirements.txt-use-correct-beautifulsoup4-package-.patch31
-rw-r--r--PKGBUILD48
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c37365d5ef8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = python-convey
+ pkgdesc = CSV processing and mutual conversion of web related data types
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/CZ-NIC/convey
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-pint
+ depends = python-chardet
+ depends = python-dateutil
+ depends = python-requests
+ depends = python-netaddr
+ depends = python-jsonpickle
+ depends = python-ipdb
+ depends = python-pythondialog
+ depends = python-validate-email
+ depends = python-tabulate
+ depends = python-appdirs
+ depends = python-humanize
+ depends = python-beautifulsoup4
+ depends = python-levenshtein
+ depends = python-prompt_toolkit
+ depends = python-pygments
+ optdepends = bind-tools: DNS information gathering with dig,
+ optdepends = nmap: port scanning,
+ optdepends = xdg-utils: opening default apps using xdg-open,
+ optdepends = whois: querying WHOIS information
+ source = https://github.com/CZ-NIC/convey/archive/1.2/convey-1.2.tar.gz
+ source = 0001-requirements.txt-use-correct-beautifulsoup4-package-.patch
+ sha256sums = c9350ab35fba4b75355181a48cdef6459e6a4269caa817783bcb2630e83e1158
+ sha256sums = a9250e5aec87e7fc6e69bb6d0054fdd93476eccaf0dd8f0ec394e9755093285a
+
+pkgname = python-convey
+
diff --git a/0001-requirements.txt-use-correct-beautifulsoup4-package-.patch b/0001-requirements.txt-use-correct-beautifulsoup4-package-.patch
new file mode 100644
index 000000000000..c747efa74f7b
--- /dev/null
+++ b/0001-requirements.txt-use-correct-beautifulsoup4-package-.patch
@@ -0,0 +1,31 @@
+From 27339d952fdc3dc317d7ee31ddabcdafefcb4c50 Mon Sep 17 00:00:00 2001
+From: Tomas Krizek <tomas.krizek@nic.cz>
+Date: Tue, 19 Nov 2019 14:14:26 +0100
+Subject: [PATCH] requirements.txt - use correct beautifulsoup4 package name
+
+The package "bs4" is only a placeholder for the actual package
+"beautifulsoup4" https://pypi.org/project/bs4/
+
+This fixes a pkg_resources import issue when installing
+convey without pip.
+---
+ requirements.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/requirements.txt b/requirements.txt
+index cf805e2..d0eaebd 100644
+--- a/requirements.txt
++++ b/requirements.txt
+@@ -10,7 +10,7 @@ validate_email
+ tabulate
+ appdirs
+ humanize
+-bs4
++beautifulsoup4
+ python-Levenshtein
+ prompt_toolkit>=2
+ pygments
+\ No newline at end of file
+--
+2.24.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..731e22e6e731
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Tomas Krizek <tomas.krizek@nic.cz>
+_pkgname=convey
+pkgname=python-${_pkgname}
+pkgver=1.2
+pkgrel=1
+pkgdesc="CSV processing and mutual conversion of web related data types"
+arch=('any')
+url="https://github.com/CZ-NIC/${_pkgname}"
+license=('GPL3')
+depends=(
+ 'python'
+ 'python-pint'
+ 'python-chardet'
+ 'python-dateutil'
+ 'python-requests'
+ 'python-netaddr'
+ 'python-jsonpickle'
+ 'python-ipdb'
+ 'python-pythondialog'
+ 'python-validate-email'
+ 'python-tabulate'
+ 'python-appdirs'
+ 'python-humanize'
+ 'python-beautifulsoup4'
+ 'python-levenshtein'
+ 'python-prompt_toolkit'
+ 'python-pygments'
+)
+optdepends=(
+ 'bind-tools: DNS information gathering with dig',
+ 'nmap: port scanning',
+ 'xdg-utils: opening default apps using xdg-open',
+ 'whois: querying WHOIS information'
+)
+source=("https://github.com/CZ-NIC/${_pkgname}/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ '0001-requirements.txt-use-correct-beautifulsoup4-package-.patch')
+sha256sums=('c9350ab35fba4b75355181a48cdef6459e6a4269caa817783bcb2630e83e1158'
+ 'a9250e5aec87e7fc6e69bb6d0054fdd93476eccaf0dd8f0ec394e9755093285a')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i "${srcdir}/0001-requirements.txt-use-correct-beautifulsoup4-package-.patch"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build install --root="${pkgdir}"
+}