summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-07-11 17:45:00 +0800
committerUniversebenzene2020-07-11 17:45:00 +0800
commit289cefefe003e2bb220da0577b5a9876a1cb916a (patch)
tree89ae577444fba9b0723892bc71561bd20a17b35d
parent99f620a93b7d858baba56c91bd8a1f70ece666eb (diff)
downloadaur-289cefefe003e2bb220da0577b5a9876a1cb916a.tar.gz
Update to 2.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 23 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c20bf4e1391..c7ad5c959d95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-corner
pkgdesc = Make some beautiful corner plots of samples
- pkgver = 2.0.1
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://pypi.python.org/pypi/corner/
arch = any
license = BSD
@@ -9,8 +9,10 @@ pkgbase = python-corner
depends = python-pytest
depends = python-nose
depends = python-pandas
- source = https://files.pythonhosted.org/packages/source/c/corner/corner-2.0.1.tar.gz
- md5sums = 148a401ebb1dff47897fe4a1389e8c77
+ depends = python-setuptools-scm
+ depends = python-wheel
+ source = https://files.pythonhosted.org/packages/source/c/corner/corner-2.1.0.tar.gz
+ md5sums = 38f04719d1ab21d10e532f6d368ad22a
pkgname = python-corner
diff --git a/PKGBUILD b/PKGBUILD
index b9e08b903a9a..4b7cd69aed0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,33 @@
# Maintainer: George C. Privon <accounts5 at privon dot com>
_pyname=corner
-pkgname=python-$_pyname
-pkgver=2.0.1
-pkgrel=2
+pkgname=python-${_pyname}
+pkgver=2.1.0
+pkgrel=1
pkgdesc='Make some beautiful corner plots of samples'
url="https://pypi.python.org/pypi/$_pyname/"
-depends=('python-matplotlib' 'python-pytest' 'python-nose' 'python-pandas')
+depends=('python-matplotlib' 'python-pytest' 'python-nose' 'python-pandas' 'python-setuptools-scm' 'python-wheel')
license=('BSD')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz")
-md5sums=('148a401ebb1dff47897fe4a1389e8c77')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('38f04719d1ab21d10e532f6d368ad22a')
build() {
- cd $srcdir/$_pyname-$pkgver
- python setup.py build
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py build
}
check() {
- cd $srcdir/$_pyname-$pkgver
- python setup.py test
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ python setup.py test
}
package() {
- cd $srcdir/$_pyname-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python setup.py install --root="${pkgdir}" --prefix=/usr --optimize=1
}