summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-12-31 13:23:01 +0000
committerGrey Christoforo2019-12-31 13:23:01 +0000
commit23380731c18ecc716ff77b65f6d53e88f139bdf0 (patch)
tree14893d76283e5363f4552856715dbeb317ca3dd5
downloadaur-23380731c18ecc716ff77b65f6d53e88f139bdf0.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05e46df1ff95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = python-cq-editor-git
+ pkgdesc = CadQuery GUI editor based on PyQT built from git
+ pkgver = 0.1RC1.r23.g1cee3f4
+ pkgrel = 1
+ url = https://github.com/CadQuery/CQ-editor
+ arch = x86_64
+ license = Apache 2.0
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
+ checkdepends = python-pytest-qt
+ checkdepends = python-pytest-mock
+ makedepends = python-setuptools
+ depends = python-cadquery
+ depends = python-pyqt5
+ depends = python-qtconsole
+ depends = python-logbook
+ depends = python-pyparsing
+ depends = python-pyqtgraph
+ depends = python-path.py
+ depends = python-requests
+ depends = spyder
+ provides = python-cq-editor
+ conflicts = python-cq-editor
+ source = git+https://github.com/CadQuery/CQ-editor.git
+ md5sums = SKIP
+
+pkgname = python-cq-editor-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ebe49b366626
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
+CQ-editor/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45f165fa59bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=python-cq-editor-git
+pkgver=0.1RC1.r23.g1cee3f4
+pkgrel=1
+pkgdesc="CadQuery GUI editor based on PyQT built from git"
+arch=('x86_64')
+url="https://github.com/CadQuery/CQ-editor"
+license=('Apache 2.0')
+provides=('python-cq-editor')
+conflicts=('python-cq-editor')
+depends=('python-cadquery' 'python-pyqt5' 'python-qtconsole' 'python-logbook' 'python-pyparsing' 'python-pyqtgraph' 'python-path.py' 'python-requests' 'spyder')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-qt' 'python-pytest-mock')
+source=("git+https://github.com/CadQuery/CQ-editor.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd CQ-editor
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd CQ-editor
+ #pytest -v --cov
+ pytest -v --cov || true
+}
+
+package() {
+ cd CQ-editor
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+