summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2021-01-18 19:38:10 +0000
committerGreyson Christoforo2021-01-18 19:38:10 +0000
commitc748671267d6d680211c1835493a8d6cc05d97cb (patch)
treec2945fbcfd314c5ae3346062dea66c1f1d59bd7f
parent756d732dd3335a0572b654970df288fa7e8d9e84 (diff)
downloadaur-c748671267d6d680211c1835493a8d6cc05d97cb.tar.gz
add build function
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cffbc954ab12..81bb9adc64d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,6 +30,7 @@ python-pytest-mock
)
source=("git+https://github.com/CadQuery/CQ-editor.git")
md5sums=('SKIP')
+options=(!strip)
pkgver() {
cd CQ-editor
@@ -42,6 +43,10 @@ prepare() {
#curl https://github.com/greyltc/CQ-editor/commit/dc2734d19b826ab90df6db58fbceb6b6a6ed2229.patch | patch -p1 # for https://github.com/CadQuery/CQ-editor/issues/174 and 122
}
+build(){
+ python setup.py build
+}
+
check() {
cd CQ-editor
#pytest -v --cov
@@ -50,6 +55,6 @@ check() {
package() {
cd CQ-editor
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}