summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2020-09-07 15:00:07 +0100
committerGreyson Christoforo2020-09-07 15:00:07 +0100
commiteb58af9754fbf1d8c86e4464099c8a0570ba8ae5 (patch)
tree598bd16d5ded322857f116c00d11ce74f67b277d
parent23380731c18ecc716ff77b65f6d53e88f139bdf0 (diff)
downloadaur-eb58af9754fbf1d8c86e4464099c8a0570ba8ae5.tar.gz
add some patches so that this works
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05e46df1ff95..bca73528a041 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-cq-editor-git
pkgdesc = CadQuery GUI editor based on PyQT built from git
- pkgver = 0.1RC1.r23.g1cee3f4
+ pkgver = 0.1.2.r15.g3a87ed0
pkgrel = 1
url = https://github.com/CadQuery/CQ-editor
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 45f165fa59bc..4a2dfd61fa55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=python-cq-editor-git
-pkgver=0.1RC1.r23.g1cee3f4
+pkgver=0.1.2.r15.g3a87ed0
pkgrel=1
pkgdesc="CadQuery GUI editor based on PyQT built from git"
arch=('x86_64')
@@ -21,6 +21,12 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd CQ-editor
+ curl https://github.com/greyltc/CQ-editor/commit/d3a0899bca7a16e4fd87ba01c69a7bf22afa7a1f.patch | patch -p1 # for https://github.com/CadQuery/CQ-editor/issues/176
+ curl https://github.com/greyltc/CQ-editor/commit/dc2734d19b826ab90df6db58fbceb6b6a6ed2229.patch | patch -p1 # for https://github.com/CadQuery/CQ-editor/issues/174 and 122
+}
+
check() {
cd CQ-editor
#pytest -v --cov