summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2020-08-01 15:12:03 +0200
committerMartino Pilia2020-08-01 15:12:03 +0200
commitc9da73272c2eec66947d8005a434f7392798a3f4 (patch)
treeed51c5fce4a9321c4c7e76d710ca2c9807cf4761
downloadaur-c9da73272c2eec66947d8005a434f7392798a3f4.tar.gz
Submit package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3496e3f58171
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-crc32c
+ pkgdesc = Implementation of the crc32c algorithm in hardware and software
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/ICRAR/crc32c
+ arch = any
+ license = LGPL2
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/ICRAR/crc32c/archive/v2.0.1.tar.gz
+ sha256sums = 599991270618bb49101cffaf7303ee2e8ffc2126450b8c7b2c7e85d3677725ea
+
+pkgname = python-crc32c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b884f3fa713
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
+_name=crc32c
+pkgname=python-${_name}
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Implementation of the crc32c algorithm in hardware and software"
+arch=('any')
+url="https://github.com/ICRAR/crc32c"
+license=('LGPL2')
+depends=('python')
+makedepends=('python-setuptools')
+source+=("https://github.com/ICRAR/crc32c/archive/v${pkgver}.tar.gz")
+sha256sums=('599991270618bb49101cffaf7303ee2e8ffc2126450b8c7b2c7e85d3677725ea')
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --optimize=1 --root="${pkgdir}"
+}