summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaruman92020-12-03 12:51:18 +0300
committersaruman92020-12-03 12:51:18 +0300
commit3ce5270e288f8a556a8e85575a3719d9bc6e1c50 (patch)
treeac87bea717b5fd84fd8fcce8a224b877a7359375
parent3960d103bba6577a20fa2c51e3d496de7459ccde (diff)
downloadaur-3ce5270e288f8a556a8e85575a3719d9bc6e1c50.tar.gz
Bump version to 1.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 619b59bf480b..4fa0c3960204 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-crccheck
pkgdesc = Calculation library for CRCs and checksums
- pkgver = 0.6
- pkgrel = 2
- url = https://bitbucket.org/martin_scharrer/crccheck
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://sourceforge.net/projects/crccheck
arch = any
license = GPL3
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/c/crccheck/crccheck-0.6.zip
- sha256sums = 5686a4e5c3a2949597316c067c49c21e06051d13de9521434480cfa24dad7e32
+ source = https://files.pythonhosted.org/packages/source/c/crccheck/crccheck-1.0.tar.gz
+ sha256sums = 17c42dc4f069308ae962b682b2974bdbf2f80ee682c7032a9df44880fca3c9ab
pkgname = python-crccheck
- depends = python
diff --git a/PKGBUILD b/PKGBUILD
index fd1470a61284..33379aa97667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=('python-crccheck')
_module=${pkgname#python-}
-pkgver='0.6'
-pkgrel=2
+pkgver='1.0'
+pkgrel=1
pkgdesc="Calculation library for CRCs and checksums"
-url="https://bitbucket.org/martin_scharrer/crccheck"
+url="https://sourceforge.net/projects/crccheck"
depends=('python')
makedepends=('python-setuptools')
license=('GPL3')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.zip")
-sha256sums=('5686a4e5c3a2949597316c067c49c21e06051d13de9521434480cfa24dad7e32')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.tar.gz")
+sha256sums=('17c42dc4f069308ae962b682b2974bdbf2f80ee682c7032a9df44880fca3c9ab')
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -20,7 +20,6 @@ build() {
}
package() {
- depends+=()
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
rm -r ${pkgdir}/usr/lib/python3.8/site-packages/tests/