summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBailey Fox2019-03-12 07:13:34 -0500
committerBailey Fox2019-03-12 07:13:34 -0500
commitcf87ad9e7ab0420478b976458e0d277b867877a8 (patch)
treebfce572dcfb7dac0907db42c1547c8cc7a04fb5e
downloadaur-cf87ad9e7ab0420478b976458e0d277b867877a8.tar.gz
Initial upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..354b413fcf9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-crccheck
+ pkgdesc = Calculation library for CRCs and checksums
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://bitbucket.org/martin_scharrer/crccheck
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/c/crccheck/crccheck-0.6.zip
+ sha256sums = 5686a4e5c3a2949597316c067c49c21e06051d13de9521434480cfa24dad7e32
+
+pkgname = python-crccheck
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3653df6adb43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Bailey Fox <bfox200012@gmail.com>
+
+pkgname=('python-crccheck')
+_module=${pkgname#python-}
+pkgver='0.6'
+pkgrel=1
+pkgdesc="Calculation library for CRCs and checksums"
+url="https://bitbucket.org/martin_scharrer/crccheck"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/${_module}/${_module}-${pkgver}.zip")
+sha256sums=('5686a4e5c3a2949597316c067c49c21e06051d13de9521434480cfa24dad7e32')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}