summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-09-20 00:03:00 +0800
committerUniversebenzene2019-09-20 00:03:00 +0800
commit661ee19652e98a03ff664633f18e18659ca139f1 (patch)
treee3d7b07ca177d76866892abd5b34075576621751
parentcdb7bdd567b53980e8d90707be2d3bcb9cab353b (diff)
downloadaur-661ee19652e98a03ff664633f18e18659ca139f1.tar.gz
Update to version 7.4.1.1
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
-rw-r--r--fix_doc_warning.patch26
4 files changed, 44 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5558b7b3c42..8c5943a039a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = python-crds-doc
pkgdesc = Documentation for STScI CRDS
- pkgver = 7.3.4
+ pkgver = 7.4.1.1
pkgrel = 1
url = https://hst-crds.stsci.edu/static/users_guide/index.html
arch = i686
arch = x86_64
license = BSD
- makedepends = python-crds=7.3.4
+ makedepends = python-crds=7.4.1.1
makedepends = python-sphinx-astropy
makedepends = python-sphinx_rtd_theme
makedepends = python-stsci_rtd_theme
- source = https://github.com/spacetelescope/crds/archive/7.3.4.tar.gz
- md5sums = 70a1f03bce0144b0e1c9c448420c8246
+ source = https://github.com/spacetelescope/crds/archive/7.4.1.1.tar.gz
+ source = fix_doc_warning.patch
+ md5sums = 3d018e7ef610ea959009495fd5c47ca0
+ md5sums = 647db347dbb750a10b37c2e24090403f
pkgname = python-crds-doc
diff --git a/.gitignore b/.gitignore
index 1df7b618a7b3..0d6e3b36c63a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@ pkg
*.tar.bz2
*.part
*.pkg.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 263cf205036b..fdbbe0fc4aac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,23 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
_pyname=crds
pkgname=python-${_pyname}-doc
-pkgver=7.3.4
+pkgver=7.4.1.1
pkgrel=1
pkgdesc="Documentation for STScI CRDS"
arch=('i686' 'x86_64')
url="https://hst-crds.stsci.edu/static/users_guide/index.html"
license=('BSD')
makedepends=("python-${_pyname}=${pkgver}" 'python-sphinx-astropy' 'python-sphinx_rtd_theme' 'python-stsci_rtd_theme')
-source=("https://github.com/spacetelescope/${_pyname}/archive/${pkgver}.tar.gz")
-md5sums=('70a1f03bce0144b0e1c9c448420c8246')
+source=("https://github.com/spacetelescope/${_pyname}/archive/${pkgver}.tar.gz"
+ 'fix_doc_warning.patch')
+md5sums=('3d018e7ef610ea959009495fd5c47ca0'
+ '647db347dbb750a10b37c2e24090403f')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
+}
build() {
cd ${srcdir}/${_pyname}-${pkgver}/documentation/crds_users_guide
diff --git a/fix_doc_warning.patch b/fix_doc_warning.patch
new file mode 100644
index 000000000000..01ab4b1744e8
--- /dev/null
+++ b/fix_doc_warning.patch
@@ -0,0 +1,26 @@
+--- a/documentation/crds_users_guide/source/file_submissions.rst 2019-09-19 05:03:33.000000000 +0800
++++ b/documentation/crds_users_guide/source/file_submissions.rst 2019-09-19 23:58:49.905655146 +0800
+@@ -443,6 +443,7 @@
+ will generate a warning.
+
+ 6. Typically for rmaps set::
++
+ * Generate Contexts ON
+ * Auto-Rename ON
+
+@@ -484,6 +485,7 @@
+ done just by submitting the new .rmap normally.
+
+ 5. Submit the .imap using Submit Mappings with::
++
+ * Generate Contexts OFF
+ * Auto-rename ON
+
+@@ -500,6 +502,7 @@
+ 2. Manually edit the .pmap to make any required changes.
+
+ 3. Submit the .pmap using Submit Mappings with::
++
+ * Generate Contexts OFF
+ * Auto-rename ON
+