summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2016-01-11 07:51:25 -0800
committerKyle Manna2016-01-11 07:51:25 -0800
commit41caa3f315c2c14e5d9a12b8c806c3ab3dfadc92 (patch)
tree05352a27c927fd35419d4e195d165fa4a5aaf756
downloadaur-41caa3f315c2c14e5d9a12b8c806c3ab3dfadc92.tar.gz
release: v1.4.0
* Initial AUR release.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64e671b96ca6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Jan 11 15:51:20 UTC 2016
+pkgbase = python-crochet
+ pkgdesc = Crochet is a library that makes it easier to use Twisted from regular blocking code
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/Storj/storjcore
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-twisted
+ source = https://pypi.python.org/packages/source/c/crochet/crochet-1.4.0.tar.gz
+ sha256sums = 51ab1c03bf4317b4a6e2b8bfd15da37674b3494f8f420eacde78e272280ae598
+
+pkgname = python-crochet
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6faae81e7886
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+*.tar.gz
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42330594dc4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
+pkgname=python-crochet
+_pkgname=${pkgname/python-/}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Crochet is a library that makes it easier to use Twisted from regular blocking code"
+url="https://github.com/Storj/storjcore"
+depends=('python' 'python-twisted')
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/c/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('51ab1c03bf4317b4a6e2b8bfd15da37674b3494f8f420eacde78e272280ae598')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+ rm -rf ${pkgdir}/usr/lib/python*/site-packages/tests/
+}
+