summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32023-11-02 22:40:50 +0100
committergilcu32023-11-02 22:40:50 +0100
commit74da75aeaa2089b1dfa3ad96eff4bcc921be4f29 (patch)
treea48e1163b99c7706d081cc0d421bb76a523467f7
downloadaur-74da75aeaa2089b1dfa3ad96eff4bcc921be4f29.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59a002f1647d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-ctranslate2-bin
+ pkgdesc = CTranslate2 is a C++ and Python library for efficient inference with Transformer models.
+ pkgver = 3.18.0
+ pkgrel = 1
+ url = https://github.com/OpenNMT/CTranslate2
+ arch = x86_64
+ license = MIT
+ makedepends = python-pip
+ depends = python>=3.7
+ provides = ctranslate2
+ conflicts = ctranslate2-git
+ conflicts = python-ctranslate2-git
+
+pkgname = python-ctranslate2-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad61d6695e4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: gilcu3
+_pkgname=ctranslate2
+pkgname=python-$_pkgname-bin
+pkgver=3.18.0
+pkgrel=1
+pkgdesc="CTranslate2 is a C++ and Python library for efficient inference with Transformer models."
+arch=('x86_64')
+url="https://github.com/OpenNMT/CTranslate2"
+license=('MIT')
+provides=("ctranslate2")
+conflicts=('ctranslate2-git' 'python-ctranslate2-git')
+depends=('python>=3.7')
+makedepends=('python-pip')
+
+package() {
+ pip install --upgrade --no-deps --ignore-installed --no-warn-script-location --root=$pkgdir $_pkgname==$pkgver
+}