summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilcu32023-11-02 23:55:32 +0100
committergilcu32023-11-02 23:55:32 +0100
commite006a077630288fb64ea56aa69a466ef9bdeb881 (patch)
tree27db38de64e9f0267ef4ba47255afebf7e21fdca
parent0957ba99979375b384f73d12b3d6fcb06a911bc4 (diff)
downloadaur-e006a077630288fb64ea56aa69a466ef9bdeb881.tar.gz
bump version; fix pycache issue
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3182cbfd8add..97caf5eaa538 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ctranslate2-bin
pkgdesc = CTranslate2 is a C++ and Python library for efficient inference with Transformer models.
- pkgver = 3.18.0
+ pkgver = 3.20.0
pkgrel = 1
url = https://github.com/OpenNMT/CTranslate2
arch = x86_64
@@ -12,5 +12,7 @@ pkgbase = python-ctranslate2-bin
provides = ctranslate2
conflicts = ctranslate2-git
conflicts = python-ctranslate2-git
+ source = https://files.pythonhosted.org/packages/cp311/c/ctranslate2/ctranslate2-3.20.0-cp311-cp311-manylinux_2_17_x86_64.manylinux2014_x86_64.whl
+ sha256sums = 80b173316e567d4117a53793235064ee00972b08a9e30065028d3373e1db8ccf
pkgname = python-ctranslate2-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5fdd47cb8601..d82c681e24dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: gilcu3
_pkgname=ctranslate2
pkgname=python-$_pkgname-bin
-pkgver=3.18.0
+pkgver=3.20.0
pkgrel=1
pkgdesc="CTranslate2 is a C++ and Python library for efficient inference with Transformer models."
arch=('x86_64')
@@ -11,7 +11,13 @@ provides=("ctranslate2")
conflicts=('ctranslate2-git' 'python-ctranslate2-git')
depends=('python>=3.7' 'python-numpy' 'python-yaml')
makedepends=('python-pip')
+_py=cp311
+wheel_name=${_pkgname//-/_}-$pkgver-$_py-${_py}-manylinux_2_17_$arch.manylinux2014_$arch.whl
+source=(https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/$_pkgname/$wheel_name)
+sha256sums=('80b173316e567d4117a53793235064ee00972b08a9e30065028d3373e1db8ccf')
package() {
- pip install --upgrade --no-deps --ignore-installed --no-warn-script-location --root=$pkgdir $_pkgname==$pkgver
+ pip install --isolated --upgrade --no-deps --ignore-installed --root=$pkgdir --no-warn-script-location $wheel_name
+ python -m compileall -d /usr "$pkgdir"/usr
+ python -O -m compileall -d /usr "$pkgdir"/usr
}