summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-10-30 11:11:57 +0000
committerGrey Christoforo2018-10-30 11:11:57 +0000
commit96e70070d12b52d0201b028f24debda62ddeb19c (patch)
tree2638cbb708782c6cc1057345510aafcd7bee37a0
downloadaur-96e70070d12b52d0201b028f24debda62ddeb19c.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54cfb2e2d073
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-cu2qu
+ pkgdesc = Cubic-to-quadratic bezier curve conversion
+ pkgver = 1.6.4
+ pkgrel = 1
+ url = https://github.com/googlei18n
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/29/33/6186137547733d15ae15ad00bc81688d474fdbb7e1aad4ee35c1d5228936/cu2qu-1.6.4.zip
+ md5sums = 5d3fe137d091286f8086588734cedb6b
+
+pkgname = python-cu2qu
+ depends = python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f40aaba69670
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6868badcc13a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=python-cu2qu
+_module=cu2qu
+pkgver=1.6.4
+pkgrel=1
+pkgdesc="Cubic-to-quadratic bezier curve conversion"
+url="https://github.com/googlei18n"
+depends=('python')
+makedepends=('python-setuptools')
+license=('Apache')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/29/33/6186137547733d15ae15ad00bc81688d474fdbb7e1aad4ee35c1d5228936/cu2qu-${pkgver}.zip")
+md5sums=('5d3fe137d091286f8086588734cedb6b')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}