summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2021-10-16 16:50:36 +1100
committerMatthew Gamble2021-10-16 16:50:36 +1100
commit5df876215a1ea5234d84e3a79d96a2edd2a7752a (patch)
tree819181cbba49b50ce3e5af379bc4b57d1b52ff29
downloadaur-5df876215a1ea5234d84e3a79d96a2edd2a7752a.tar.gz
Initial publish on AUR
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d21b58eb36c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-cuddle
+ pkgdesc = Python implementation of the KDL Document Language
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/djmattyg007/python-cuddle
+ arch = any
+ license = MIT
+ makedepends = python-poetry-core
+ makedepends = python-setuptools
+ depends = python
+ depends = python-regex
+ depends = python-tatsu
+ source = https://pypi.io/packages/source/c/cuddle/cuddle-1.0.3.tar.gz
+ sha256sums = a5d7066544c8d7d5025436482113a4b03c0595772b9796b393a6414eece716a1
+
+pkgname = python-cuddle
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2125d9f968ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.tar.gz
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8297d1c3b238
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+pkgname=python-cuddle
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Python implementation of the KDL Document Language"
+arch=("any")
+url="https://github.com/djmattyg007/python-cuddle"
+license=("MIT")
+depends=("python" "python-regex" "python-tatsu")
+makedepends=("python-poetry-core" "python-setuptools")
+source=("https://pypi.io/packages/source/c/cuddle/cuddle-${pkgver}.tar.gz")
+sha256sums=("a5d7066544c8d7d5025436482113a4b03c0595772b9796b393a6414eece716a1")
+
+build() {
+ cd "cuddle-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "cuddle-${pkgver}"
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-cuddle/LICENSE.txt"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/python-cuddle/README.md"
+ install -Dm644 CHANGELOG.md "${pkgdir}/usr/share/doc/python-cuddle/CHANGELOG.md"
+}