summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Owens2020-04-30 21:38:55 -0500
committerNathan Owens2020-04-30 21:39:04 -0500
commit77358fe7e4f4252748d4bc7f3095c4c0f0c07221 (patch)
tree3f8b6865ce78a9245eae4ef35a95aebf20b7e6a5
parent80887902f960286907591361255a147db0afad3f (diff)
downloadaur-77358fe7e4f4252748d4bc7f3095c4c0f0c07221.tar.gz
Update to 2.2.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD55
2 files changed, 19 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99d7b83faa89..7665c3f8e318 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,17 @@
pkgbase = python-custom_inherit
- pkgdesc = A Python package that provides tools for inheriting docstrings in customizable ways
- pkgver = 2.2.0
+ pkgdesc = Python package that provides tools for inheriting docstrings in customizable ways
+ pkgver = 2.2.2
pkgrel = 1
url = https://github.com/meowklaski/custom_inherit
arch = any
license = MIT
makedepends = python
makedepends = python-setuptools
- makedepends = python2
- makedepends = python2-setuptools
+ makedepends = git
+ depends = python
options = !emptydirs
- source = python-custom_inherit-2.2.0.tar.gz::https://pypi.io/packages/source/c/custom_inherit/custom_inherit-2.2.0.tar.gz
- source = https://raw.githubusercontent.com/meowklaski/custom_inherit/13bce675e246d84e21bcd7658e0a4fbf25db4adc/License.md
- sha256sums = 3892ec53aaffae98d757867c3d1dd5f02200db0e1f888ab601223d72262996f8
- sha256sums = 3ec37cf6e3bd177bf8661a0cd5f5d59b9955700a70bfd5ff12bd30d6d12ca95e
+ source = git+https://github.com/meowklaski/custom_inherit#tag=v2.2.2
+ sha256sums = SKIP
pkgname = python-custom_inherit
- depends = python
-
-pkgname = python2-custom_inherit
- depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index e49130891ea6..742d7284b8d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,27 @@
# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
-_name=custom_inherit
-pkgbase='python-custom_inherit'
-pkgname=('python-custom_inherit' 'python2-custom_inherit')
-pkgver=2.2.0
+pkgname=python-custom_inherit
+pkgver=2.2.2
pkgrel=1
-pkgdesc="A Python package that provides tools for inheriting docstrings in customizable ways"
+pkgdesc="Python package that provides tools for inheriting docstrings in customizable ways"
arch=('any')
url="https://github.com/meowklaski/custom_inherit"
license=('MIT')
-makedepends=(
- 'python' 'python-setuptools'
- 'python2' 'python2-setuptools')
+depends=('python')
+makedepends=('python' 'python-setuptools' 'git')
options=(!emptydirs)
-source=(
- "${pkgname}"-"${pkgver}".tar.gz::https://pypi.io/packages/source/"${_name:0:1}"/"${_name}"/"${_name}"-"${pkgver}".tar.gz
- https://raw.githubusercontent.com/meowklaski/custom_inherit/13bce675e246d84e21bcd7658e0a4fbf25db4adc/License.md
-)
-sha256sums=(
- '3892ec53aaffae98d757867c3d1dd5f02200db0e1f888ab601223d72262996f8'
- '3ec37cf6e3bd177bf8661a0cd5f5d59b9955700a70bfd5ff12bd30d6d12ca95e'
-)
-
-prepare() {
- cp -a custom_inherit-"${pkgver}"{,-py2}
-}
-
-package() {
- cd "${srcdir}"/custom_inherit-"${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
-}
+source=("git+https://github.com/meowklaski/custom_inherit#tag=v${pkgver}")
+sha256sums=('SKIP')
build(){
- cd "${srcdir}"/custom_inherit-"${pkgver}"
+ cd "${srcdir}"/custom_inherit
python setup.py build
-
- cd "${srcdir}"/custom_inherit-"${pkgver}"-py2
- python2 setup.py build
}
-package_python2-custom_inherit() {
- depends=('python2')
-
- install -Dm644 License.md "${pkgdir}"/usr/share/licenses/"${pkgname}"/License.md
- cd custom_inherit-"${pkgver}"-py2
- python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
-}
-
-package_python-custom_inherit() {
- depends=('python')
-
- install -Dm644 License.md "${pkgdir}"/usr/share/licenses/"${pkgname}"/License.md
- cd custom_inherit-"${pkgver}"
+package() {
+ cd "${srcdir}"/custom_inherit
python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+
+ install -Dm644 LICENSE.md "${pkgdir}"/usr/share/licenses/"${pkgname}"/License
}