summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2021-04-05 22:09:18 +0200
committerFrancesco Minnocci2021-04-05 22:09:18 +0200
commit3faa754c8ce31f9cb49d4ab276c9a44a32183d1b (patch)
tree6a5d185d1e05d483779f6ee8cb8abc2a16792d1c
downloadaur-3faa754c8ce31f9cb49d4ab276c9a44a32183d1b.tar.gz
Initial package upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de3a65cac543
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-cutie
+ pkgdesc = Command line User Tools for Input Easification
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/Kamik423/cutie
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-colorama
+ depends = python-readchar
+ source = https://pypi.org/packages/source/c/cutie/cutie-0.2.2.tar.gz
+ source = https://raw.githubusercontent.com/Kamik423/cutie/master/license.md
+ source = https://raw.githubusercontent.com/Kamik423/cutie/master/readme.md
+ sha256sums = 5e38711dedc2efec4f62290f30bc9ad4b489de33fe2d84efafb3611971bc4a91
+ sha256sums = b9a6af81b2d9c1ee676c80ba084e15a8d4d81b108ec01e9464dd73aa5f6e55ae
+ sha256sums = 3252f16614750de229409cb373108d496f434287b85024eceb4948185e393b80
+
+pkgname = python-cutie
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e5702907c0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: yochanamarqos
+
+pkgname=python-cutie
+_name=${pkgname#python-}
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Command line User Tools for Input Easification"
+arch=('any')
+url="https://github.com/Kamik423/cutie"
+license=('MIT')
+depends=('python' 'python-colorama' 'python-readchar')
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/Kamik423/cutie/master/license.md"
+ "https://raw.githubusercontent.com/Kamik423/cutie/master/readme.md")
+sha256sums=('5e38711dedc2efec4f62290f30bc9ad4b489de33fe2d84efafb3611971bc4a91'
+ 'b9a6af81b2d9c1ee676c80ba084e15a8d4d81b108ec01e9464dd73aa5f6e55ae'
+ '3252f16614750de229409cb373108d496f434287b85024eceb4948185e393b80')
+
+prepare() {
+ cd "$_name-$pkgver"
+
+ # readme.md missing in PyPI tarball
+ ln -s "$srcdir/readme.md" readme.md
+}
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 "$srcdir/license.md" -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+# vim:set ts=2 sw=2 et: