summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-01-10 14:13:15 -0500
committerGuillaume Horel2017-01-10 14:13:15 -0500
commit5d102b010dae4b860440f574e762dd9939095d03 (patch)
tree26118834515398aeb93ae7592076a55ad686b7a6
parent44d97afbc9edb61de29b1f847583e29da04683c8 (diff)
downloadaur-5d102b010dae4b860440f574e762dd9939095d03.tar.gz
add missing patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--use_system_eigen.patch33
3 files changed, 39 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 830183810f79..b1cf974f592f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,9 @@ pkgbase = python-cvxcanon
depends = python-numpy
depends = python-scipy
source = https://github.com/cvxgrp/CVXcanon/archive/v0.1.1.tar.gz
+ source = use_system_eigen.patch
md5sums = ea900f44c30596d96999aa61eab89f08
+ md5sums = ee7c698d9fb8bdd767c96015850a6869
pkgname = python-cvxcanon
diff --git a/PKGBUILD b/PKGBUILD
index 40ebc7d53775..47144d572962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,10 @@ makedepends=('python-setuptools'
'eigen')
license=('unknown')
arch=('i686' 'x86_64')
-source=("https://github.com/cvxgrp/CVXcanon/archive/v${pkgver}.tar.gz")
-md5sums=('ea900f44c30596d96999aa61eab89f08')
+source=("https://github.com/cvxgrp/CVXcanon/archive/v${pkgver}.tar.gz"
+ "use_system_eigen.patch")
+md5sums=('ea900f44c30596d96999aa61eab89f08'
+ 'ee7c698d9fb8bdd767c96015850a6869')
prepare() {
cd "${srcdir}/${_module}-${pkgver}"
diff --git a/use_system_eigen.patch b/use_system_eigen.patch
new file mode 100644
index 000000000000..6be37efb23ab
--- /dev/null
+++ b/use_system_eigen.patch
@@ -0,0 +1,33 @@
+Only in CVXcanon-0.1.1-orig/build: temp.linux-x86_64-3.6
+diff -aur CVXcanon-0.1.1-orig/setup.py CVXcanon-0.1.1/setup.py
+--- CVXcanon-0.1.1-orig/setup.py 2017-01-10 13:39:21.161947185 -0500
++++ CVXcanon-0.1.1/setup.py 2017-01-10 13:39:54.981932516 -0500
+@@ -7,7 +7,7 @@
+ canon = Extension(
+ '_CVXcanon',
+ sources=['src/CVXcanon.cpp', 'src/LinOpOperations.cpp', 'src/python/CVXcanon_wrap.cpp'],
+- include_dirs=['src/', 'src/python/', 'include/Eigen', numpy.get_include()]
++ include_dirs=['src/', 'src/python/', '/usr/include/eigen3', numpy.get_include()]
+ )
+
+ base_dir = os.path.dirname(__file__)
+diff -aur CVXcanon-0.1.1-orig/src/Utils.hpp CVXcanon-0.1.1/src/Utils.hpp
+--- CVXcanon-0.1.1-orig/src/Utils.hpp 2017-01-10 13:38:30.215304531 -0500
++++ CVXcanon-0.1.1/src/Utils.hpp 2017-01-10 13:40:18.425256236 -0500
+@@ -15,12 +15,12 @@
+
+ // Some useful defines for Matricies/etc.
+
+-#include "../include/Eigen/Sparse"
+-#include "../include/Eigen/Core"
++#include "Eigen/Sparse"
++#include "Eigen/Core"
+
+ #define NULL_MATRIX Eigen::SparseMatrix<double>(0,0)
+
+ typedef Eigen::Matrix<int, Eigen::Dynamic, 1> Vector;
+ typedef Eigen::SparseMatrix<double> Matrix;
+ typedef std::map<int, Matrix> CoeffMap;
+-typedef Eigen::Triplet<double> Triplet;
+\ No newline at end of file
++typedef Eigen::Triplet<double> Triplet;