summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJC Francois2018-10-06 13:50:44 +0200
committerJC Francois2018-10-06 13:50:44 +0200
commitb1ede0ea6a3ac286df0ebde51b7ec75422c92d66 (patch)
tree39839be8b67b2eacd46be8cc0786955d3653e619
downloadaur-b1ede0ea6a3ac286df0ebde51b7ec75422c92d66.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d0dba5a93fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-cysystemd
+ pkgdesc = SystemD wrapper on Cython
+ pkgver = 0.17.1
+ pkgrel = 1
+ url = http://github.com/mosquito/cysystemd
+ arch = any
+ license = Apache
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-cysystemd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35ebdf2b0e57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# PKGBUILD generated by pipman
+# Python package author: Dmitry Orlov <me@mosquito.su> <me@mosquito.su>
+pkgname=python-cysystemd
+pkgver=0.17.1
+pkgrel=1
+pkgdesc="SystemD wrapper on Cython"
+arch=(any)
+url="http://github.com/mosquito/cysystemd"
+license=(Apache)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="cysystemd" cysystemd
+}
+package() {
+ mkdir -p $pkgdir/usr/lib/python3.7/site-packages/
+ cp -r $srcdir/cysystemd/* $pkgdir/usr/lib/python3.7/site-packages/
+} \ No newline at end of file