summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2015-06-11 09:05:57 -0700
committerJonathan Yantis2015-06-11 09:05:57 -0700
commit8432f703d27da209e7e21df3e4ddf670969e2624 (patch)
tree376834a8031c4fe603386e8fbd03c66f3ab41611
downloadaur-python-cytoolz-git.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c2cba27f943
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-cytoolz-git
+ pkgdesc = Cython implementation of Toolz for Python 3. High performance functional utilities.
+ pkgver = 0.7.4dev.r172.c9f6b06
+ pkgrel = 2
+ url = http://github.com/pytoolz/cytoolz
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = cython
+ makedepends = python-nose
+ depends = python
+ provides = python-cytoolz
+ conflicts = python-cytoolz
+ source = git+http://github.com/pytoolz/cytoolz.git
+ sha256sums = SKIP
+
+pkgname = python-cytoolz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..104618a03a85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: jyantis <yantis@yantis.net>
+
+pkgname=python-cytoolz-git
+pkgver=0.7.4dev.r172.c9f6b06
+pkgrel=2
+pkgdesc='Cython implementation of Toolz for Python 3. High performance functional utilities.'
+arch=('any')
+url='http://github.com/pytoolz/cytoolz'
+license=('BSD')
+depends=('python')
+source=('git+http://github.com/pytoolz/cytoolz.git')
+sha256sums=('SKIP')
+makedepends=('git' 'python-setuptools' 'cython' 'python-nose')
+provides=('python-cytoolz')
+conflicts=('python-cytoolz')
+
+pkgver() {
+ cd cytoolz
+ set -o pipefail
+ _gitversion=$( git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+
+ if [ -f "cytoolz/_version.py" ]; then
+ printf "%s.%s" "$(grep -R "__version__ =" cytoolz/_version.py | awk -F\' '{print $2}')" $_gitversion | sed 's/-/./g'
+ else
+ printf "%s" $_gitversion
+ fi
+}
+build() {
+ cd cytoolz
+
+ python setup.py build
+}
+
+package() {
+ cd cytoolz
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}
+
+# vim:set ts=2 sw=2 et: