summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Joram2022-04-02 15:41:37 +0300
committerPhilipp Joram2022-04-02 15:44:18 +0300
commitbf779b01cd36558cd45e53ada568a13fdd4f410f (patch)
tree108958599138666d4823dc04393d110dd2796c84
parentd042a6ab9c07de720c790a154d8c6752565cca6f (diff)
downloadaur-bf779b01cd36558cd45e53ada568a13fdd4f410f.tar.gz
Provide missing license file
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD11
3 files changed, 32 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16670266db40..6e950fc123e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-dacite
pkgdesc = Simplify creation of data classes (PEP 557) from dictionaries.
pkgver = 1.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/konradhalas/dacite
arch = any
license = MIT
makedepends = python-setuptools
depends = python
source = https://files.pythonhosted.org/packages/source/d/dacite/dacite-1.6.0.tar.gz
+ source = LICENSE
sha512sums = d34b4dfd1192cb285a7cc34da8a87cfda87129db9b3ac026a7ce3dc01d227093b6db920c6eba148fc8a4be1d0fec57f50b117877419419d06264ad1a79ffaa15
+ sha512sums = e6962f48291088edaf156bcb8c3be115e3695c5f90c367e2a60f6061ce8f9be42472be6b4d20b8ecdd610c7143935b9b8e838e2e9236a07c8f706b69fddfa2a7
pkgname = python-dacite
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4be5be76271c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Konrad Hałas
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6b51f541aa31..57ca6b7b4b09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,18 @@
pkgname='python-dacite'
_name=${pkgname#python-}
pkgver=1.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simplify creation of data classes (PEP 557) from dictionaries."
url="https://github.com/konradhalas/dacite"
arch=('any')
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha512sums=('d34b4dfd1192cb285a7cc34da8a87cfda87129db9b3ac026a7ce3dc01d227093b6db920c6eba148fc8a4be1d0fec57f50b117877419419d06264ad1a79ffaa15')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "LICENSE" # License file is not included in PyPI tarball.
+ )
+sha512sums=('d34b4dfd1192cb285a7cc34da8a87cfda87129db9b3ac026a7ce3dc01d227093b6db920c6eba148fc8a4be1d0fec57f50b117877419419d06264ad1a79ffaa15'
+ 'e6962f48291088edaf156bcb8c3be115e3695c5f90c367e2a60f6061ce8f9be42472be6b4d20b8ecdd610c7143935b9b8e838e2e9236a07c8f706b69fddfa2a7')
build() {
cd "${_name}-${pkgver}"
@@ -21,6 +24,8 @@ build() {
package() {
cd "${_name}-${pkgver}"
python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: