summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Joram2022-03-30 14:49:12 +0300
committerPhilipp Joram2022-03-30 14:56:51 +0300
commitd042a6ab9c07de720c790a154d8c6752565cca6f (patch)
tree9e9613e72cbf68c999fecab3e0422030827a7c84
downloadaur-d042a6ab9c07de720c790a154d8c6752565cca6f.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16670266db40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-dacite
+ pkgdesc = Simplify creation of data classes (PEP 557) from dictionaries.
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/konradhalas/dacite
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/d/dacite/dacite-1.6.0.tar.gz
+ sha512sums = d34b4dfd1192cb285a7cc34da8a87cfda87129db9b3ac026a7ce3dc01d227093b6db920c6eba148fc8a4be1d0fec57f50b117877419419d06264ad1a79ffaa15
+
+pkgname = python-dacite
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b51f541aa31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Philipp Joram <mail [at] phijor [dot] me>
+
+pkgname='python-dacite'
+_name=${pkgname#python-}
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="Simplify creation of data classes (PEP 557) from dictionaries."
+url="https://github.com/konradhalas/dacite"
+arch=('any')
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha512sums=('d34b4dfd1192cb285a7cc34da8a87cfda87129db9b3ac026a7ce3dc01d227093b6db920c6eba148fc8a4be1d0fec57f50b117877419419d06264ad1a79ffaa15')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: