summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2024-02-16 10:34:16 -0500
committerGuillaume Horel2024-02-16 10:34:16 -0500
commitcd5ea2c3f1a575b99417a90e7a80778b34d750e2 (patch)
tree259c548e93bcb0b5c4740d03c145d227daa3c089
parent3e71402f7e675e8708647e12b10c1e6626dd9bff (diff)
downloadaur-python-dash.tar.gz
bump to 2.15.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 35 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b208a073f9f1..a9f17fd17ed4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,25 @@
pkgbase = python-dash
pkgdesc = A python framework for building analytical web applications
- pkgver = 2.14.0
+ pkgver = 2.15.0
pkgrel = 1
url = https://plot.ly/products/dash/
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
depends = python-flask
- depends = python-flask-compress
- depends = python-flask-seasurf
- depends = python-future
+ depends = python-importlib-metadata
+ depends = python-nest-asyncio
depends = python-plotly
depends = python-requests
+ depends = python-retrying
+ depends = python-setuptools
+ depends = python-yaml
+ depends = python-werkzeug
+ optdepends = python-flask-compress
provides = python-dash-core-components
provides = python-dash-html-components
provides = python-dash-renderer
@@ -21,7 +28,7 @@ pkgbase = python-dash
conflicts = python-dash-html-components
conflicts = python-dash-renderer
conflicts = python-dash-table
- source = https://pypi.org/packages/source/d/dash/dash-2.14.0.tar.gz
- sha256sums = bd28be70be24ae1d1f764b8217a03da35e9ed895406686d24dfb6ed4e331e5a9
+ source = https://pypi.org/packages/source/d/dash/dash-2.15.0.tar.gz
+ sha256sums = d38891337fc855d5673f75e5346354daa063c4ff45a8a6a21f25e858fcae41c2
pkgname = python-dash
diff --git a/PKGBUILD b/PKGBUILD
index 23ad20e54117..f5919b9e292f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,43 @@
pkgname=python-dash
_pkgname=dash
-pkgver=2.14.0
+pkgver=2.15.0
pkgrel=1
pkgdesc="A python framework for building analytical web applications"
arch=('any')
url="https://plot.ly/products/dash/"
license=('MIT')
-depends=('python' 'python-flask' 'python-flask-compress' 'python-flask-seasurf' 'python-future' 'python-plotly' 'python-requests')
-optdepends=()
-makedepends=('python-setuptools')
+depends=(
+ python
+ python-flask
+ python-importlib-metadata
+ python-nest-asyncio
+ python-plotly
+ python-requests
+ python-retrying
+ python-setuptools
+ python-yaml
+ python-werkzeug
+)
+optdepends=(python-flask-compress)
+makedepends=(python-build python-installer python-setuptools python-wheel)
provides=('python-dash-core-components' 'python-dash-html-components' 'python-dash-renderer' 'python-dash-table')
conflicts=('python-dash-core-components' 'python-dash-html-components' 'python-dash-renderer' 'python-dash-table')
source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('bd28be70be24ae1d1f764b8217a03da35e9ed895406686d24dfb6ed4e331e5a9')
+sha256sums=('d38891337fc855d5673f75e5346354daa063c4ff45a8a6a21f25e858fcae41c2')
build(){
cd "$_pkgname-$pkgver"
- python setup.py build
+ python -m build -wn
}
package(){
cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mkdir -p "${pkgdir}/etc/xdg"
+ mv "${pkgdir}/usr/etc/jupyter" "${pkgdir}/etc/xdg"
+ rmdir "${pkgdir}/usr/etc"
}
## vim:ts=2:sw=2:et: