summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-09-23 09:39:51 -0400
committerGuillaume Horel2021-09-23 09:39:51 -0400
commit63de83faa4d0b96359e8165159591af9a590126c (patch)
tree9c08f06ba9b44655f3f2510abb0be2f89497f485
parentb8eec68a8ce02bb8f2ea28c2bbd03d01a52d7517 (diff)
downloadaur-63de83faa4d0b96359e8165159591af9a590126c.tar.gz
bump to 2.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 21 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a2da94a3840..fc1ecdbc848e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
pkgbase = python-dash
pkgdesc = A python framework for building analytical web applications
- pkgver = 1.21.0
+ pkgver = 2.0.0
pkgrel = 1
url = https://plot.ly/products/dash/
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-dash-renderer
- depends = python-dash-core-components
- depends = python-dash-html-components
+ depends = python
depends = python-flask
depends = python-flask-compress
depends = python-flask-seasurf
depends = python-future
depends = python-plotly
depends = python-requests
- source = https://pypi.org/packages/source/d/dash/dash-1.21.0.tar.gz
- sha256sums = 8b03a53e4f7a5f3eded8af099ff54d9981f7879d22d74c7970b9a27c8f698ebb
+ provides = python-dash-core-components
+ provides = python-dash-html-components
+ provides = python-dash-table
+ conflicts = python-dash-core-components
+ conflicts = python-dash-html-components
+ conflicts = python-dash-table
+ source = https://pypi.org/packages/source/d/dash/dash-2.0.0.tar.gz
+ sha256sums = 29277c24e2f795b069cb102ce1ab0cd3ad5cf9d3b4fd16c03da9671a5eea28a4
pkgname = python-dash
diff --git a/PKGBUILD b/PKGBUILD
index 4f1adf209909..89be0e00d839 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,27 @@
pkgname=python-dash
_pkgname=dash
-pkgver=1.21.0
+pkgver=2.0.0
pkgrel=1
pkgdesc="A python framework for building analytical web applications"
arch=('any')
url="https://plot.ly/products/dash/"
license=('MIT')
-depends=('python-dash-renderer' 'python-dash-core-components' 'python-dash-html-components' 'python-flask' 'python-flask-compress' 'python-flask-seasurf' 'python-future' 'python-plotly' 'python-requests')
+depends=('python' 'python-flask' 'python-flask-compress' 'python-flask-seasurf' 'python-future' 'python-plotly' 'python-requests')
optdepends=()
makedepends=('python-setuptools')
+provides=('python-dash-core-components' 'python-dash-html-components' 'python-dash-table')
+conflicts=('python-dash-core-components' 'python-dash-html-components' 'python-dash-table')
source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('8b03a53e4f7a5f3eded8af099ff54d9981f7879d22d74c7970b9a27c8f698ebb')
+sha256sums=('29277c24e2f795b069cb102ce1ab0cd3ad5cf9d3b4fd16c03da9671a5eea28a4')
+build(){
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
package(){
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
## vim:ts=2:sw=2:et: