summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-01-27 12:02:53 -0500
committerGuillaume Horel2018-01-27 12:02:53 -0500
commit6f0f9174c42c4e94db0a5d8b16f38a8b44a61aec (patch)
tree4113691fa42fb6c15888419fd67968bee724c5da
downloadaur-6f0f9174c42c4e94db0a5d8b16f38a8b44a61aec.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecad53ca9da7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-dash-core-components
+ pkgdesc = Dash UI core components suite
+ pkgver = 0.18.1
+ pkgrel = 1
+ url = https://plot.ly/products/dash
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.org/packages/source/d/dash_core_components/dash_core_components-0.18.1.tar.gz
+ sha256sums = 96764f9c30f2348eac618b53178e0d1c5fa1cb0c7dfc41914ef2b6876e26271e
+
+pkgname = python-dash-core-components
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a1bd8c0808d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=python-dash-core-components
+_pkgname=dash_core_components
+pkgver=0.18.1
+pkgrel=1
+pkgdesc="Dash UI core components suite"
+arch=('any')
+url="https://plot.ly/products/dash"
+license=('MIT')
+depends=('python')
+optdepends=()
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('96764f9c30f2348eac618b53178e0d1c5fa1cb0c7dfc41914ef2b6876e26271e')
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+#check(){
+# cd "$srcdir/$_pkgname-$pkgver"
+# python -m unittest
+#}
+# vim:ts=2:sw=2:et: