summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-10-16 17:26:12 +0100
committerGrey Christoforo2019-10-16 17:26:12 +0100
commit3b84e01049da13beb914bd004487a776b41b078d (patch)
tree20f3af4ea6e3cd853da5f92277f23e4d937c5bdd
downloadaur-3b84e01049da13beb914bd004487a776b41b078d.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecced76c77a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-dash-daq
+ pkgdesc = Control components for Dash
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://github.com/plotly/dash-daq
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-dash
+ source = https://github.com/plotly/dash-daq/archive/v0.2.2.tar.gz
+ sha256sums = 0909d5556760f8caa7e2b3e8c48e4e4e812cb1a66422e4c59ceb7cee498982c1
+
+pkgname = python-dash-daq
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c451bad976c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-dash-daq
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Control components for Dash"
+arch=('any')
+url=https://github.com/plotly/dash-daq
+license=('MIT')
+depends=(python python-dash)
+makedepends=(python-setuptools)
+source=(https://github.com/plotly/dash-daq/archive/v${pkgver}.tar.gz)
+sha256sums=('0909d5556760f8caa7e2b3e8c48e4e4e812cb1a66422e4c59ceb7cee498982c1')
+
+prepare() {
+ cd "$srcdir/dash-daq-$pkgver"
+ #versioneer install
+}
+
+build() {
+ cd "$srcdir/dash-daq-$pkgver"
+ python setup.py build
+}
+
+
+package() {
+ cd "$srcdir/dash-daq-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:ts=2:sw=2:et: