summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-10-17 15:29:45 +0100
committerGrey Christoforo2019-10-17 15:29:45 +0100
commit6f49cbbd5fc47f0668eb65790710e0f4d1aee892 (patch)
tree202f10b98981b38799e1e3a32bb45934481d64fb
parent3b84e01049da13beb914bd004487a776b41b078d (diff)
downloadaur-6f49cbbd5fc47f0668eb65790710e0f4d1aee892.tar.gz
fix build
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c451bad976c1..a172ce6bbe2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,20 @@ pkgdesc="Control components for Dash"
arch=('any')
url=https://github.com/plotly/dash-daq
license=('MIT')
-depends=(python python-dash)
-makedepends=(python-setuptools)
+depends=(python python-dash python-dash-table)
+makedepends=(python-setuptools yarn)
source=(https://github.com/plotly/dash-daq/archive/v${pkgver}.tar.gz)
sha256sums=('0909d5556760f8caa7e2b3e8c48e4e4e812cb1a66422e4c59ceb7cee498982c1')
prepare() {
cd "$srcdir/dash-daq-$pkgver"
+ rm yarn.lock
+ rm package-lock.json
+ yarn
+ python get_version_info.py
+ yarn copy-lib
+ dash-generate-components ./src/components dash_daq -p package-info.json --r-prefix 'daq'
+
#versioneer install
}