summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2018-01-27 12:01:06 -0500
committerGuillaume Horel2018-01-27 12:01:06 -0500
commit4770bbdb60ec0f2e9903434c018d1b5f1ca472e5 (patch)
treeccb74976e7b2091d375c6b7ba2fa5b2bf21c908e
downloadaur-4770bbdb60ec0f2e9903434c018d1b5f1ca472e5.tar.gz
original import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..374312b93572
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-dash-html-components
+ pkgdesc = Dash UI HTML components suite
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://plot.ly/products/dash
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.org/packages/source/d/dash_html_components/dash_html_components-0.8.0.tar.gz
+ sha256sums = 5fe4a5966388078468a502fa1e93cf94a856ad4ae7d27022544facc0ee4e75cf
+
+pkgname = python-dash-html-components
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e181c72b527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=python-dash-html-components
+_pkgname=dash_html_components
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Dash UI HTML components suite"
+arch=('any')
+url="https://plot.ly/products/dash"
+license=('MIT')
+depends=('python')
+optdepends=()
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('5fe4a5966388078468a502fa1e93cf94a856ad4ae7d27022544facc0ee4e75cf')
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+#check(){
+# cd "$srcdir/$_pkgname-$pkgver"
+# python -m unittest
+#}
+# vim:ts=2:sw=2:et: