summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël Donval2016-09-03 17:57:28 +0200
committerGaël Donval2016-09-03 17:57:28 +0200
commit7270811a86dc21e5021709e62231fffccff595a6 (patch)
tree331a0e8cb54351173df0915e5a13885ca8dc64a0
downloadaur-7270811a86dc21e5021709e62231fffccff595a6.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecbd055a6e31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-datashape
+ pkgdesc = Data description protocol for dynd similar to Numpy DTypes.
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = https://github.com/blaze/datashape
+ arch = any
+ groups = blaze-ecosystem
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-numpy>=1.7
+ depends = python>=3.4
+ depends = python-multipledispatch>=0.4.7
+ depends = python-dateutil
+ source = https://github.com/blaze/datashape/archive/0.5.3.tar.gz
+ md5sums = e243704f530ef7520ad9d5a70d337683
+ sha1sums = e79b5eb684a698509cf8d46138fa717fa6826e2a
+
+pkgname = python-datashape
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d81fa2b0058
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gaël Donval <gdonval+aur at google mail>
+# Contributor: Gaël Donval <gdonval+aur at google mail>
+
+pkgbase='python-datashape'
+pkgname=('python-datashape')
+pkgver=0.5.3
+pkgrel=1
+pkgdesc='Data description protocol for dynd similar to Numpy DTypes.'
+arch=('any')
+url='https://github.com/blaze/datashape'
+license=('BSD')
+groups=('blaze-ecosystem')
+makedepends=('python-setuptools')
+depends=('python-numpy>=1.7'
+ 'python>=3.4'
+ 'python-multipledispatch>=0.4.7'
+ 'python-dateutil')
+source=("https://github.com/blaze/datashape/archive/${pkgver}.tar.gz")
+sha1sums=('e79b5eb684a698509cf8d46138fa717fa6826e2a')
+md5sums=('e243704f530ef7520ad9d5a70d337683')
+
+build() {
+ cd "${srcdir}"/datashape-$pkgver
+ python setup.py build
+}
+
+package_python-datashape() {
+ cd "${srcdir}"/datashape-$pkgver
+ python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE* "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README* "${pkgdir}/usr/share/doc/${pkgname}/README"
+}