summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2020-07-27 12:19:06 +0300
committerAnton Kudelin2020-07-27 12:19:06 +0300
commit380334ac3e90d27e481165f82743983c1e3ba6c6 (patch)
treecd90b64a2fb3c71aff8aa4503d38e038d363c429
parent9ee4452c64900e49104f04e8d4e584916ce98e14 (diff)
downloadaur-380334ac3e90d27e481165f82743983c1e3ba6c6.tar.gz
Small fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0b34c0cb6ac..cf3c7c03e1b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-dateutils
pkgdesc = Utilities for working with datetime objects.
pkgver = 0.6.8
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/plytophogy/python-dateutils
arch = any
- license = BSD
+ license = Unlicense
depends = python-dateutil
depends = python-argparse
depends = python-pytz
diff --git a/PKGBUILD b/PKGBUILD
index 65c4b8be79bc..381116567571 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
-# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
-pkgname=python-dateutils
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Contributor: Hans-Nikolai Viessmann <hans AT viess.mn>
+
_pkgname=dateutils
+pkgname=python-$_pkgname
pkgver=0.6.8
-pkgrel=1
+pkgrel=2
pkgdesc="Utilities for working with datetime objects."
arch=('any')
url="https://github.com/plytophogy/python-dateutils"
-license=('BSD')
+license=('Unlicense')
depends=('python-dateutil' 'python-argparse' 'python-pytz')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('15e564d9cd34e4260cf96625a3249c938c3aada2e5eaddf8218dd3fbc8dbdba4')
prepare() {
- cd "${_pkgname}-${pkgver}"
- # for some reason the PyPi version is missing some fixes found in the repo to make it python3 compatible.
- sed -e 's/print dt.strftime(args.format)/print(dt.strftime(args.format))/' -i "${_pkgname}/dateadd.py"
- sed -e 's/print __import__(args.unit)(end_dt, start_dt, \*\*kwargs)/print(__import__(args.unit)(end_dt, start_dt, \*\*kwargs))/' -i "${_pkgname}/datediff.py"
+ cd "${_pkgname}-${pkgver}"
+ # for some reason the PyPi version is missing some fixes found in the repo to make it python3 compatible.
+ sed -e 's/print dt.strftime(args.format)/print(dt.strftime(args.format))/' -i "${_pkgname}/dateadd.py"
+ sed -e 's/print __import__(args.unit)(end_dt, start_dt, \*\*kwargs)/print(__import__(args.unit)(end_dt, start_dt, \*\*kwargs))/' -i "${_pkgname}/datediff.py"
}
build() {
- cd "${_pkgname}-${pkgver}"
- /usr/bin/python setup.py build
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
}
package() {
- cd "${_pkgname}-${pkgver}"
- /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-
- # License is missing
- #install -Dm644 LICENSE "$pkdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}