summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-03-17 18:02:38 -0700
committerclintval2018-03-17 18:02:38 -0700
commit90e0d10e5d001842bcf0d739f2f57196d1236329 (patch)
treed9df54c48ca538bf32bfa381cf74e1310e7b57c9
downloadaur-90e0d10e5d001842bcf0d739f2f57196d1236329.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fd7d33d4346
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-datrie
+ pkgdesc = LZ-string compression for Python
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/datrie
+ arch = any
+ license = (L)GPL2
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-datrie-0.7.1.tar.gz::https://pypi.python.org/packages/44/5f/bf7e4711f6aa95edb2216b3487eeac719645802259643d341668e65636db/datrie-0.7.1.tar.gz
+ sha256sums = 7a11371cc2dbbad71d6dfef57ced6e8b384bb377eeb847c63d58f8dc8e8b2023
+
+pkgname = python-datrie
+ depends = python
+
+pkgname = python2-datrie
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cd21d9ad94d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+_name=datrie
+pkgbase='python-datrie'
+pkgname=('python-datrie' 'python2-datrie')
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="LZ-string compression for Python"
+arch=('any')
+url="https://pypi.python.org/pypi/datrie"
+license=('(L)GPL2')
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+options=(!emptydirs)
+source=("${pkgname}"-"${pkgver}".tar.gz::https://pypi.python.org/packages/44/5f/bf7e4711f6aa95edb2216b3487eeac719645802259643d341668e65636db/datrie-0.7.1.tar.gz)
+sha256sums=('7a11371cc2dbbad71d6dfef57ced6e8b384bb377eeb847c63d58f8dc8e8b2023')
+
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
+
+package_python2-datrie() {
+ depends=('python2')
+
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}
+
+package_python-datrie() {
+ depends=('python')
+
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}