summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2018-07-13 18:38:52 +0300
committerDaniel Bershatsky2018-07-13 18:38:52 +0300
commit61421b9eedd819ef4c6e3904c0fcff3a8d267c39 (patch)
tree05f182208cc5c7ccf203d7d367c3718fbb27745f
parent62156f6bef3a6c38445334839650a0228974292b (diff)
downloadaur-61421b9eedd819ef4c6e3904c0fcff3a8d267c39.tar.gz
Force remove system modules.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f704919b2354..295b94ff4b4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,7 @@ pkgbase = python-dbg
depends = openssl
depends = libffi
depends = zlib
+ provides = python
options = !debug
options = !strip
source = https://www.python.org/ftp/python/3.6.6/Python-3.6.6.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index a4f1a429d2c2..ab635c4be157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-dbg
pkgver=3.6.6
-pkgrel=1
+pkgrel=2
epoch=0
pkgdesc="Python 3 debug symbols."
arch=('i686' 'x86_64')
@@ -34,9 +34,9 @@ prepare() {
# Ensure that we are using the system copy of various libraries (expat, libffi, and libmpdec),
# rather than copies shipped in the tarball
- rm -r Modules/expat
- rm -r Modules/_ctypes/{darwin,libffi}*
- rm -r Modules/_decimal/libmpdec
+ rm -rf Modules/expat
+ rm -rf Modules/_ctypes/{darwin,libffi}*
+ rm -rf Modules/_decimal/libmpdec
}
build() {