summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSemyon Maryasin2020-02-11 22:46:55 +0300
committerSemyon Maryasin2020-02-11 22:46:55 +0300
commite353d65bbd119c7a2c52c593b2ae638c4da944a9 (patch)
tree56df0b817d0da4fb002f1dfec531f519d2959965
downloadaur-e353d65bbd119c7a2c52c593b2ae638c4da944a9.tar.gz
Initial ver
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13856f0f13c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-dbus-next
+ pkgdesc = The next great DBus library for Python with asyncio support
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/altdesktop/python-dbus-next
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/d/dbus-next/dbus_next-0.1.2.tar.gz
+ md5sums = df838d695284dd1775860f9691a8663f
+
+pkgname = python-dbus-next
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f846f3a4f30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname='python-dbus-next'
+_module='dbus_next'
+pkgver=0.1.2
+pkgrel=1
+pkgdesc='The next great DBus library for Python with asyncio support'
+url=https://github.com/altdesktop/python-dbus-next
+arch=('any')
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+provices=('python-dbus-next', 'dbus-next')
+source=("https://files.pythonhosted.org/packages/source/d/dbus-next/${_module}-${pkgver}.tar.gz")
+md5sums=('df838d695284dd1775860f9691a8663f')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}