summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFichteFoll2018-04-27 16:35:34 +0200
committerFichteFoll2018-04-27 16:35:34 +0200
commit2321d8a94054281153ad3572c85451b04fda9502 (patch)
treea49c2f2d60793b2627c0fab72a5a767401350b1a
downloadaur-2321d8a94054281153ad3572c85451b04fda9502.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76775f5ce314
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-dbussy-git
+ pkgdesc = Python binding for D-Bus using asyncio
+ pkgver = r447.cc89ae8
+ pkgrel = 1
+ url = https://github.com/ldo/dbussy
+ arch = any
+ license = LGPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ provides = python-dbussy
+ conflicts = python-dbussy
+ source = python-dbussy::git+https://github.com/ldo/dbussy
+ sha256sums = SKIP
+
+pkgname = python-dbussy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4575b85dc7c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: FichteFoll <fichtefoll2@googlemail.com>
+
+_pkgbase=python-dbussy
+# _name=${_pkgbase#python-}
+pkgname="${_pkgbase}-git"
+pkgver=r447.cc89ae8
+pkgrel=1
+pkgdesc="Python binding for D-Bus using asyncio"
+arch=(any)
+url="https://github.com/ldo/dbussy"
+license=('LGPL')
+depends=('python')
+makedepends=('git' 'python-setuptools')
+provides=("${_pkgbase}")
+conflicts=("${_pkgbase}")
+source=("${_pkgbase}::git+https://github.com/ldo/dbussy")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgbase}"
+ (
+ set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}